Bug 173075 - Problems running Eclipse [was: Can't reinstall eclipse]
Problems running Eclipse [was: Can't reinstall eclipse]
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-13 12:49 EST by Kim Lux
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 12:41:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kim Lux 2005-11-13 12:49:17 EST
Description of problem: 
 
I uninstalled eclipse and now it doesn't re install properly.  
 
Version-Release number of selected component (if applicable): 
 
3.3.1 
 
How reproducible: 
 
Won't re install every time.  
 
Steps to Reproduce: 
 
See bug# 116141 at www.eclipse.org. 
 
I post here because I don't know if this is a Fedora issue with the eclipse 
RPMs or an eclipse issue.  
 
BTW: cdt-3.0.1 is out and there is a patch for eclipse bug # 84647 that should 
be rolled into cdt-3.0.1
Comment 1 Kim Lux 2005-11-13 12:51:26 EST
The version should be 3.1.1, not 3.3.1.   
Comment 2 Kim Lux 2005-11-14 04:21:51 EST
 
After a lot of work, I figured this problem out.  
 
First of all, the FC4 eclipse from the FC4 repository rpms ran terribly on my 
computer.  I highly doubt they are actually version 3.1.1 because the 3.1.1 
eclipse.org has a different splash screen. 
 
Secondly, I experienced a lot of errors running them on my machine, all I 
believe, related to Fedora's Java setup.  
 
So... the solution to this problem was to: 
 
a) uninstall the FC4 RPMs. 
 
b) remove the /usr/share/eclipse directory 
 
c) install Sun's Java JDK (or JRE) FROM SOURCE.  See 
http://fedoranews.org/mediawiki/index.php/JPackage_Java_for_FC4 
These instructions are excellent.  They worked very well.  
 
d) install eclipse and accessories by downloading SDK from www.eclipse.org and 
doing a tar -zxf of these (as root) from /usr/share.  (Will 
make /usr/share/eclipse and all the sub directories.) 
 
See bug # 116141 at www.eclipse.org for my experience and some comments on 
what took place with respect to this bug.  
 
The only side effect so far from installing Sun's Java is that evolution seems 
faster and the fonts changed on a few things, not necessarily for the worse, 
either.  
 
I wasted a ton of time figuring this all out.  I hope this helps someone.  
  
Comment 3 Andrew Overholt 2005-11-14 09:25:06 EST
(In reply to comment #2)
>  
> First of all, the FC4 eclipse from the FC4 repository rpms ran terribly on my 
> computer.  I highly doubt they are actually version 3.1.1 because the 3.1.1 
> eclipse.org has a different splash screen. 

It *is* 3.1.1 but we change the splash screen.  I'm sorry to hear that it did
not meet your expectations.  Can you perhaps provide some more details so that
we can figure out what the problem is?  What architecture are you running?  What
kernel version?  What gcc version?  What version of the Eclipse RPMs?

> Secondly, I experienced a lot of errors running them on my machine, all I 
> believe, related to Fedora's Java setup.  



> So... the solution to this problem was to: 
>  
> a) uninstall the FC4 RPMs. 

You mean the FC4 Eclipse RPMs?

> b) remove the /usr/share/eclipse directory 

This shouldn't be necessary.  This directory shouldn't be around anymore if you
remove all the Eclipse RPMs (including libswt3-gtk2).

> c) install Sun's Java JDK (or JRE) FROM SOURCE.  See 
> http://fedoranews.org/mediawiki/index.php/JPackage_Java_for_FC4 
> These instructions are excellent.  They worked very well.  

Please understand that this is unacceptable for many users as it is not free
software.  I hope you also know that we cannot distribute this with Fedora.

> d) install eclipse and accessories by downloading SDK from www.eclipse.org and 
> doing a tar -zxf of these (as root) from /usr/share.  (Will 
> make /usr/share/eclipse and all the sub directories.) 

This is not the recommended way of installing software on Fedora.  While you may
obviously do as you wish with your machine, I would caution against putting
things in / (as root) unless you really know what you are doing.  Why not just
run upstream Eclipse releases from your home directory?

> The only side effect so far from installing Sun's Java is that evolution seems 
> faster and the fonts changed on a few things, not necessarily for the worse, 
> either.  

I don't see how evolution could possibly be faster.

> I wasted a ton of time figuring this all out.  I hope this helps someone.  

Again, I'm sorry you had to spend time on this.  I really do believe, however,
that your situation is unique as I haven't heard anyone have this trouble.  As I
said before, I'd like to work this out so that we can find the root of the
problem and hopefully save others from it.
Comment 4 Kim Lux 2005-11-14 15:17:39 EST
   
Comments below.  
  
  
=============================================================================  
> First of all, the FC4 eclipse from the FC4 repository rpms ran terribly on  
my   
> computer.  I highly doubt they are actually version 3.1.1 because the 3.1.1   
> eclipse.org has a different splash screen.   
  
It *is* 3.1.1 but we change the splash screen.  I'm sorry to hear that it did  
not meet your expectations.   
  
==============================================================================  
  
First of all, why did you change the splash screen ?  
  
If you changed that, what else was changed ?  
  
  
==============================================================================  
 Can you perhaps provide some more details so that we can figure out what the  
problem is?   
==============================================================================  
  
I am not running the FC4 eclipse any more.  To see some of the examples of  
problems, view the bugs I logged into www.eclipse.org.  Generally, eclipse  
would randomly crash.  I got flashing and disappearing error messages when I  
logged in.    
  
============================================================================  
What architecture are you running?  What  
kernel version?  What gcc version?  What version of the Eclipse RPMs?  
============================================================================  
  
$uname -a  
Linux zd7280 2.6.13-1.1526_FC4smp #1 SMP Wed Sep 28 19:30:04 EDT 2005 i686  
i686 i386 GNU/Linux  
$ rpm -q gcc  
gcc-4.0.1-4.fc4  
  
System totally stock FC4 except KDE-3.4.3.1-FC4 installed via RPMs.  All  
up2date updates done.    
  
I'd do some testing on other machines before you proclaim eclipse to run  
properly.   
I installed the Fedora Eclipse from the extra repository rpms using Synaptic.   
  
For example, the platform rpm was 1:3.1.1-1-jpp-1fc.FC4.4.   
 
=============================================================================  
> Secondly, I experienced a lot of errors running them on my machine, all I   
> believe, related to Fedora's Java setup.    
  
  
> So... the solution to this problem was to:   
>    
> a) uninstall the FC4 RPMs.   
 
You mean the FC4 Eclipse RPMs?  
========================================================================= 
 
Yes. 
 
 
=========================================================================  
> b) remove the /usr/share/eclipse directory   
  
This shouldn't be necessary.  This directory shouldn't be around anymore if  
you  
remove all the Eclipse RPMs (including libswt3-gtk2). 
========================================================================== 
 
It is necessary.  libswt3-gtk2 is NOT listed as a dependency for the eclipse 
platform, but I believe it probably should be.  
  
  
========================================================================== 
> c) install Sun's Java JDK (or JRE) FROM SOURCE.  See   
> http://fedoranews.org/mediawiki/index.php/JPackage_Java_for_FC4   
> These instructions are excellent.  They worked very well.    
  
Please understand that this is unacceptable for many users as it is not free  
software.  I hope you also know that we cannot distribute this with Fedora. 
========================================================================== 
 
I do understand that and I appreciate that Fredora cannot go that route.  That 
is OK.  I provided this so that other users experiencing the same problems as 
me have a solution.  
 
 
============================================================================ 
> d) install eclipse and accessories by downloading SDK from www.eclipse.org  
and   
> doing a tar -zxf of these (as root) from /usr/share.  (Will   
> make /usr/share/eclipse and all the sub directories.)   
  
This is not the recommended way of installing software on Fedora.  While you  
may  
obviously do as you wish with your machine, I would caution against putting  
things in / (as root) unless you really know what you are doing.  Why not just  
run upstream Eclipse releases from your home directory? 
============================================================================== 
 
Sure.  My box is multi user.  How I got started doing it this way is because 
this is where FC4 puts eclipse and I set $PATH to point there, so I just kept 
it like that.   
 
  
===============================================================================  
> The only side effect so far from installing Sun's Java is that evolution  
seems   
> faster and the fonts changed on a few things, not necessarily for the worse,   
> either.    
  
I don't see how evolution could possibly be faster. 
============================================================================== 
 
It must have some java in it.  I am running KDE-3.4.3-1. The fonts changed so 
what does that tell us ?  
 
 
  
========================================================================== 
> I wasted a ton of time figuring this all out.  I hope this helps someone.    
  
Again, I'm sorry you had to spend time on this.  I really do believe, however,  
that your situation is unique as I haven't heard anyone have this trouble.  As  
I said before, I'd like to work this out so that we can find the root of the  
problem and hopefully save others from it.  
========================================================================== 
 
 
I'm not ragging on you about this.  It happened and so be it.  Fedora software 
generally works very well.  Linux Rocks!   
 
At this juncture I can't go back and test this with you, but I will in the 
future.  I can go back to the Fedora Java at will using /sbin/alternatives... 
in 2 minutes.    
 
Let me ask you this: should the Eclipse.org install work properly with the 
Fedora Java ?  Ie: should the Sun Java install have been necessary ?   
 
Comment 5 Andrew Overholt 2005-11-14 15:37:50 EST
(In reply to comment #4)
 
> =============================================================================  
> > First of all, the FC4 eclipse from the FC4 repository rpms ran terribly on  
> my   
> > computer.  I highly doubt they are actually version 3.1.1 because the 3.1.1   
> > eclipse.org has a different splash screen.   
>   
> It *is* 3.1.1 but we change the splash screen.  I'm sorry to hear that it did  
> not meet your expectations.   
>   
> ==============================================================================  
>   
> First of all, why did you change the splash screen ?  

The main reason was so that we could differentiate our natively-compiled builds
from the upstream releases.  We didn't want people bugging upstream about issues
that are Fedora-specific.  This type of differentiation is encouraged by
upstream.  If you don't agree, by all means file a bug (in RH bugzilla).  There
is currently a bug open about having the splash screen be JVM-dependent (ie.
show the "native" one when being run with gij/gcj and show the upstream one
otherwise).

> If you changed that, what else was changed ?  

You can see what was changed by looking at the specfile/SRPM in Fedora CVS. 
Generally, only minor patches (many of them build machinery patches) are applied.

> ==============================================================================  
>  Can you perhaps provide some more details so that we can figure out what the  
> problem is?   
> ==============================================================================  
>   
> I am not running the FC4 eclipse any more.  To see some of the examples of  
> problems, view the bugs I logged into www.eclipse.org.  Generally, eclipse  
> would randomly crash.  I got flashing and disappearing error messages when I  
> logged in.    

You entered more than one bug?  Can you tell me what the other ones were?

> I'd do some testing on other machines before you proclaim eclipse to run  
> properly.   

I run Eclipse on many different machines as well as regularly on ppc and x86
(not so much on x86_64) and I *never* have the problems you are reporting. 
Also, I have yet to hear from others having the same problems.  If this is as
bad as you suggest, why haven't we heard from other people?

> =========================================================================  
> > b) remove the /usr/share/eclipse directory   
>   
> This shouldn't be necessary.  This directory shouldn't be around anymore if  
> you  
> remove all the Eclipse RPMs (including libswt3-gtk2). 
> ========================================================================== 
>  
> It is necessary.  libswt3-gtk2 is NOT listed as a dependency for the eclipse 
> platform, but I believe it probably should be.  

What do you mean it's not "listed as a dependency"?  It's a hard dependency in
the specfile AFAICT.  I spent some time ensuring that *everything* in the RPMs
is accounted for by the %files lists.  Please open bugs (in RH bugzilla) if this
is not the case.

> =============================================================================  
> > The only side effect so far from installing Sun's Java is that evolution  
> seems   
> > faster and the fonts changed on a few things, not necessarily for the worse,   
> > either.    
>   
> I don't see how evolution could possibly be faster. 
> ============================================================================= 
>  
> It must have some java in it.  I am running KDE-3.4.3-1. The fonts changed so 
> what does that tell us ?  

I have no idea why the fonts changed but there is no java code in evolution for
sure.

> Let me ask you this: should the Eclipse.org install work properly with the 
> Fedora Java ?

Yes *.

> Ie: should the Sun Java install have been necessary ?   

No *.

What we ship with Fedora should work out of the box.  Installing additional
software to make it work should not be necessary.

* I am not saying that we don't have bugs that are not there when you run with
the Sun JVM, but in general our Eclipse packages work well and we work hard to
make sure there are as few bugs as possible.
Comment 6 Kim Lux 2005-11-14 16:26:03 EST
    
> why did you change the splash screen ?   
 
>The main reason was so that we could differentiate our natively-compiled 
>builds from the upstream releases.  We didn't want people bugging upstream 
>about issues that are Fedora-specific.  This type of differentiation is 
>encouraged by upstream.  If you don't agree, by all means file a bug (in RH 
>bugzilla).   
 
**** I see and understand your point.  I am not sure that changing the splash 
screen was the best way to do the differentiation.  
 
>There is currently a bug open about having the splash screen be JVM-dependent 
>(ie. show the "native" one when being run with gij/gcj and show the upstream 
>one otherwise). 
 
**** I agree with being able to tell which java one is running with is a good 
thing, but again I am not sure that changing the splashscreen is the way to do 
it.  Eclipse is OS.  How about adding it to the About menu.  Easy to do.     
 
 
> If you changed that, what else was changed ?   
>You can see what was changed by looking at the specfile/SRPM in Fedora CVS.  
>Generally, only minor patches (many of them build machinery patches) are 
>applied. 
 
OK.  
 
 
>You entered more than one bug?  Can you tell me what the other ones were? 
 
OK.  116088 116113 at eclipse.org.  I had more problems, but I didn't log 
them.  Eclipse works fine now.   
 
>I run Eclipse on many different machines as well as regularly on ppc and x86 
>(not so much on x86_64) and I *never* have the problems you are reporting.  
>Also, I have yet to hear from others having the same problems.  If this is as 
>bad as you suggest, why haven't we heard from other people? 
 
I am wondering if I had a non Fedora jvm installed prior to all this that 
messed up the Fedora jvm.  My FC4 came from an FC3 update and I did have a jvm 
installed in FC3.  Installing the Sun JVM as per the instructions in the link 
cleaned everything up.    
 
 
> libswt3-gtk2 is NOT listed as a dependency for the eclipse  
> platform, but I believe it probably should be.   
> What do you mean it's not "listed as a dependency"?  
 
In Synaptic, if I select Eclipse for install, it doesn't show up in the must 
install list.  And it isn't uninstalling it when I remove Exclipse.  
 
>It's a hard dependency in 
>the specfile AFAICT.  I spent some time ensuring that *everything* in the 
>RPMs is accounted for by the %files lists.  Please open bugs (in RH bugzilla) 
>if this is not the case. 
 
At one point that lib was "not found" in an Eclipse error log.  When I did an 
rpm -q on it, it wasn't installed.  Dunno how that happened.  I didn't check 
the list itself with rpm.   
 
 
> I don't see how evolution could possibly be faster.  
> 
=============================================================================  
>   
> It must have some java in it.  I am running KDE-3.4.3-1. The fonts changed 
so  
> what does that tell us ?   
>I have no idea why the fonts changed but there is no java code in evolution  
> for 
> sure. 
 
Hmmmm....  I dunno.  
 
 
> Let me ask you this: should the Eclipse.org install work properly with the  
> Fedora Java ? 
>Yes *. 
 
OK.  I'll test it when I get caught up around here.  I'll send error logs if 
there are errors.  
 
> Ie: should the Sun Java install have been necessary ?    
>No *. 
 
OK.  This is a good discussion.  I'll change back and see what happens.  
 
>What we ship with Fedora should work out of the box.  Installing additional 
>software to make it work should not be necessary. 
 
Are there any changes made in Eclipse to work with the Eclipse.org version 
versus the FC4 version ? 
 
 
>* I am not saying that we don't have bugs that are not there when you run 
>with the Sun JVM, but in general our Eclipse packages work well and we work 
>hard to make sure there are as few bugs as possible. 
 
I understand.  
 
I'll get back to you with error logs (or not)  
 
Comment 7 Kim Lux 2005-11-14 16:44:39 EST
OK... here is an example.  Open an empty eclipse project and change the
perspective to "Java Browsing"  With the Java jvm, everything works fine.

With the FC4 jvm, I get the following on the command line:

Unhandled event loop exception
Reason:
java.util.ConcurrentModificationException

I get this in an error window:

Java.lang.ClassNotFoundException: org.eclipse.jdt.internal.ui.browsing.TypesView
   at
org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(java.lang.String,
boolean) (Unknown Source)
   at
org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(java.lang.String)
(Unknown Source)
   at
org.eclipse.osgi.framework.adaptor.core.AbstractClassLoader.loadClass(java.lang.String,
boolean) (Unknown Source)
   at java.lang.ClassLoader.loadClass(java.lang.String) (/usr/lib/libgcj.so.6.0.0)
   at
org.eclipse.osgi.framework.internal.core.BundleLoader.loadClass(java.lang.String)
(Unknown Source)
   at
org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(java.lang.String,
boolean) (Unknown Source)
   at
org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass(java.lang.String)
(Unknown Source)
   at
org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(org.osgi.framework.Bundle,
java.lang.String, java.lang.Object,
org.eclipse.core.internal.registry.ConfigurationElement, java.lang.String)
(Unknown Source)
   at
org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(java.lang.String,
java.lang.String, java.lang.Object,
org.eclipse.core.internal.registry.ConfigurationElement, java.lang.String)
(Unknown Source)
   at
org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(java.lang.String)
(Unknown Source)
   at
org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(java.lang.String)
(Unknown Source)
   at org.eclipse.ui.internal.WorkbenchPlugin$1.run() (Unknown Source)
   at
org.eclipse.swt.custom.BusyIndicator.showWhile(org.eclipse.swt.widgets.Display,
java.lang.Runnable) (Unknown Source)
   at
org.eclipse.ui.internal.WorkbenchPlugin.createExtension(org.eclipse.core.runtime.IConfigurationElement,
java.lang.String) (Unknown Source)
   at org.eclipse.ui.internal.registry.ViewDescriptor.createView() (Unknown Source)
   at org.eclipse.ui.internal.ViewReference.createPartHelper() (Unknown Source)
   at org.eclipse.ui.internal.ViewReference.createPart() (Unknown Source)
   at org.eclipse.ui.internal.WorkbenchPartReference.getPart(boolean) (Unknown
Source)
   at org.eclipse.ui.internal.PartPane.setVisible(boolean) (Unknown Source)
   at org.eclipse.ui.internal.ViewPane.setVisible(boolean) (Unknown Source)
   at org.eclipse.ui.internal.presentations.PresentablePart.setVisible(boolean)
(Unknown Source)
   at
org.eclipse.ui.internal.presentations.util.PresentablePartFolder.select(org.eclipse.ui.presentations.IPresentablePart)
(Unknown Source)
   at
org.eclipse.ui.internal.presentations.util.LeftToRightTabOrder.select(org.eclipse.ui.presentations.IPresentablePart)
(Unknown Source)
   at
org.eclipse.ui.internal.presentations.util.TabbedStackPresentation.selectPart(org.eclipse.ui.presentations.IPresentablePart)
(Unknown Source)
   at org.eclipse.ui.internal.PartStack.refreshPresentationSelection() (Unknown
Source)

Comment 8 Andrew Overholt 2005-11-14 17:01:35 EST
(In reply to comment #6)
>
> **** I agree with being able to tell which java one is running with is a good 
> thing, but again I am not sure that changing the splashscreen is the way to do 
> it.  Eclipse is OS.  How about adding it to the About menu.  Easy to do.     

That change is there in rawhide now :)  Actually, I'm building right now with
that change.

> >I run Eclipse on many different machines as well as regularly on ppc and x86 
> >(not so much on x86_64) and I *never* have the problems you are reporting.  
> >Also, I have yet to hear from others having the same problems.  If this is as 
> >bad as you suggest, why haven't we heard from other people? 
>  
> I am wondering if I had a non Fedora jvm installed prior to all this that 
> messed up the Fedora jvm.  My FC4 came from an FC3 update and I did have a jvm 
> installed in FC3.  Installing the Sun JVM as per the instructions in the link 
> cleaned everything up.    

That's possible.  The multiple JVM situation is a little difficult to get right
across updates sometimes.

> > libswt3-gtk2 is NOT listed as a dependency for the eclipse  
> > platform, but I believe it probably should be.   
> > What do you mean it's not "listed as a dependency"?  
>  
> In Synaptic, if I select Eclipse for install, it doesn't show up in the must 
> install list.  And it isn't uninstalling it when I remove Exclipse.  

I don't know why this happens.  I've never used Synaptic.  I can guarantee you
that yum pulls it in and that rpm will complain if it's not installed or in the
transaction if trying to install eclipse-platform.  It isn't removed if you rpm
-e eclipse-platform because it can be useful standalone for apps such as RSSOwl
or Azureus (neither of which are in Fedora Extras right now but hopefully will
be eventually).

> > Let me ask you this: should the Eclipse.org install work properly with the  
> > Fedora Java ? 
> >Yes *. 
>  
> OK.  I'll test it when I get caught up around here.  I'll send error logs if 
> there are errors.  

Thank you.

> >What we ship with Fedora should work out of the box.  Installing additional 
> >software to make it work should not be necessary. 
>  
> Are there any changes made in Eclipse to work with the Eclipse.org version 
> versus the FC4 version ? 

I'm not really sure what you mean here but I think the answer is no.  As a user
you really shouldn't notice anything different (except for the odd libgcj issue
... most of the native compilation issues have been sorted out now (we hope)).

Comment 9 Andrew Overholt 2005-11-14 17:09:35 EST
(In reply to comment #7)
> OK... here is an example.  Open an empty eclipse project and change the
> perspective to "Java Browsing"  With the Java jvm, everything works fine.
> 
> With the FC4 jvm, I get the following on the command line:
> 
> Unhandled event loop exception
> Reason:
> java.util.ConcurrentModificationException

I cannot reproduce this.  Perhaps something got messed up with your db.  Try
"sudo rebuild-gcj-db /usr/lib" (or "rebuild-gcj-db /usr/lib" as root) .. no quotes.
Comment 10 Kim Lux 2005-11-14 17:21:21 EST
"That change is there in rawhide now :)  Actually, I'm building right now with    
that change."    
    
EXCELLENT !  And thanks for your open attitude in discussing this.     
   
==============================================================================  
Quote:   
> In Synaptic, if I select Eclipse for install, it doesn't show up in the must    
> install list.  And it isn't uninstalling it when I remove Exclipse.     
   
I don't know why this happens.  I've never used Synaptic.  I can guarantee you   
that yum pulls it in and that rpm will complain if it's not installed or in   
the transaction if trying to install eclipse-platform.  It isn't removed if   
you rpm -e eclipse-platform because it can be useful standalone for apps such   
as RSSOwl or Azureus (neither of which are in Fedora Extras right now but   
hopefully will be eventually).   
==============================================================================   
   
  
I know about why it might not be used.  Errr... can I ask another question ?    
Why did Fedora change the name of the Eclipse packages ?  Why didn't the   
platform + jdt and other essentials stay as the SDK, not that I like that name   
either ?  It is just confusing to go back and forth and figure out what is   
what.    
   
BTW: I much prefer the FC4 method of install (rpms) to the Eclipse installs   
(manually copy and untarring *.tar.gz files.)    
  
  
  
==============================================================================  
Quote:  
> Are there any changes made in Eclipse to work with the Eclipse.org version   
> versus the FC4 version ?   
  
I'm not really sure what you mean here but I think the answer is no.  As a  
user  
you really shouldn't notice anything different (except for the odd libgcj  
issue  
... most of the native compilation issues have been sorted out now (we hope)).  
==============================================================================  
  
I was just wondering if any of the jvm calls had to changed/rewritten to use  
the FC4 jvm.  
 
 
============================================================================= 
Quote: 
I cannot reproduce this.  Perhaps something got messed up with your db.  Try 
"sudo rebuild-gcj-db /usr/lib" (or "rebuild-gcj-db /usr/lib" as root) .. no 
quotes. 
============================================================================== 
 
Standby while I test this.  
 
 
   
Comment 11 Kim Lux 2005-11-14 17:29:37 EST
I did the rebuild and received a different error message. 
 
Still not error free, but it changed.  
 
I'll test more if you have suggestions.  
 
 
java.lang.ClassNotFoundException: 
org.eclipse.jdt.internal.ui.browsing.TypesView 
   at 
org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(java.lang.String, 
boolean) (Unknown Source) 
   at 
org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(java.lang.String) 
(Unknown Source) 
   at 
org.eclipse.osgi.framework.adaptor.core.AbstractClassLoader.loadClass(java.lang.String, 
boolean) (Unknown Source) 
   at java.lang.ClassLoader.loadClass(java.lang.String) 
(/usr/lib/libgcj.so.6.0.0) 
   at 
org.eclipse.osgi.framework.internal.core.BundleLoader.loadClass(java.lang.String) 
(Unknown Source) 
   at 
org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(java.lang.String, 
boolean) (Unknown Source) 
   at 
org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass(java.lang.String) 
(Unknown Source) 
   at 
org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(org.osgi.framework.Bundle, 
java.lang.String, java.lang.Object, 
org.eclipse.core.internal.registry.ConfigurationElement, java.lang.String) 
(Unknown Source) 
   at 
org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(java.lang.String, 
java.lang.String, java.lang.Object, 
org.eclipse.core.internal.registry.ConfigurationElement, java.lang.String) 
(Unknown Source) 
   at 
org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(java.lang.String) 
(Unknown Source) 
   at 
org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(java.lang.String) 
(Unknown Source) 
   at org.eclipse.ui.internal.WorkbenchPlugin$1.run() (Unknown Source) 
   at 
org.eclipse.swt.custom.BusyIndicator.showWhile(org.eclipse.swt.widgets.Display, 
java.lang.Runnable) (Unknown Source) 
   at 
org.eclipse.ui.internal.WorkbenchPlugin.createExtension(org.eclipse.core.runtime.IConfigurationElement, 
java.lang.String) (Unknown Source) 
   at org.eclipse.ui.internal.registry.ViewDescriptor.createView() (Unknown 
Source) 
   at org.eclipse.ui.internal.ViewReference.createPartHelper() (Unknown 
Source) 
   at org.eclipse.ui.internal.ViewReference.createPart() (Unknown Source) 
   at org.eclipse.ui.internal.WorkbenchPartReference.getPart(boolean) (Unknown 
Source) 
   at org.eclipse.ui.internal.PartPane.setVisible(boolean) (Unknown Source) 
   at org.eclipse.ui.internal.ViewPane.setVisible(boolean) (Unknown Source) 
   at 
org.eclipse.ui.internal.presentations.PresentablePart.setVisible(boolean) 
(Unknown Source) 
   at 
org.eclipse.ui.internal.presentations.util.PresentablePartFolder.select(org.eclipse.ui.presentations.IPresentablePart) 
(Unknown Source) 
   at 
org.eclipse.ui.internal.presentations.util.LeftToRightTabOrder.select(org.eclipse.ui.presentations.IPresentablePart) 
(Unknown Source) 
   at 
org.eclipse.ui.internal.presentations.util.TabbedStackPresentation.selectPart(org.eclipse.ui.presentations.IPresentablePart) 
(Unknown Source) 
   at org.eclipse.ui.internal.PartStack.refreshPresentationSelection() 
(Unknown Source) 
 
Comment 12 Ben Konrath 2006-10-04 12:41:33 EDT
This bug is filed against FC4 which is no longer supported. Please re-test with
FC5 or FC6 and reopen the bug if the problem still exists. Thanks.

Note You need to log in before you can comment on or make changes to this bug.