Bug 1730755 - Error 'Can't read Java functions library, aborting' issued when starting tomcat.service up.
Summary: Error 'Can't read Java functions library, aborting' issued when starting tomc...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tomcat
Version: 30
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Ivan Afonichev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-17 14:27 UTC by F.Prates
Modified: 2019-08-15 18:51 UTC (History)
6 users (show)

Fixed In Version: tomcat-9.0.21-2.fc30 tomcat-9.0.21-2.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-15 18:09:39 UTC


Attachments (Terms of Use)

Description F.Prates 2019-07-17 14:27:22 UTC
Description of problem:
Error 'Can't read Java functions library, aborting' issued when starting tomcat.service up.
it seems like 'javapackages-tools.noarch' should be a requirement for tomcat.noarch

Version-Release number of selected component (if applicable):
9.0.21-1.fc30

How reproducible:
always, when javapackages-tools.noarch is not installed.

Steps to Reproduce:
1.sudo dnf install tomcat
2.systemctl start tomcat.service
3.systemctl status tomcat.service

Actual results:
'sudo dnf install tomcat' has no 'javapackages-tools.noarch' listed as a dependency.

Expected results:
have javapackages-tools.noarch installed as a dependency.

Additional info:
none.

Comment 3 Fedora Update System 2019-08-06 18:15:58 UTC
FEDORA-2019-cc796c2b23 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-cc796c2b23

Comment 4 Fedora Update System 2019-08-06 18:16:02 UTC
FEDORA-2019-2b7fe4a7de has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-2b7fe4a7de

Comment 5 Fedora Update System 2019-08-07 01:07:52 UTC
tomcat-9.0.21-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-2b7fe4a7de

Comment 6 F.Prates 2019-08-07 01:39:55 UTC
I didn't work for me. I've followed the provided updates_testing instructions, but if I missed something, please, feel free to tell me.

Follow bellow did i proceed with the test and its output:

$ sudo dnf install tomcat --enablerepo=updates-testing
Fedora 30 - x86_64 - Test Updates                51 kB/s |  40 kB     00:00    
Dependências resolvidas.
================================================================================
 Package                  Arch     Version              Repository         Size
================================================================================
Instalando:
 tomcat                   noarch   1:9.0.21-1.fc30      updates            90 k
Instalando dependências:
 ecj                      noarch   1:4.11-0.1.fc30      updates-testing   2.6 M
 tomcat-el-3.0-api        noarch   1:9.0.21-1.fc30      updates           104 k
 tomcat-jsp-2.3-api       noarch   1:9.0.21-1.fc30      updates            64 k
 tomcat-lib               noarch   1:9.0.21-1.fc30      updates           5.2 M
 tomcat-servlet-4.0-api   noarch   1:9.0.21-1.fc30      updates           283 k
 apache-commons-daemon    x86_64   1.0.15-19.fc30       fedora             55 k
Instalando dependências fracas:
 tomcat-native            x86_64   1.2.21-1.fc30        updates            74 k

Resumo da transação
================================================================================
Instalar  8 Pacotes

Tamanho total do download: 8.5 M
Tamanho depois de instalado: 10 M
Correto? [s/N]: s
Baixando pacotes:
(1/8): tomcat-9.0.21-1.fc30.noarch.rpm          776 kB/s |  90 kB     00:00    
(2/8): tomcat-jsp-2.3-api-9.0.21-1.fc30.noarch. 1.7 MB/s |  64 kB     00:00    
(3/8): tomcat-el-3.0-api-9.0.21-1.fc30.noarch.r 413 kB/s | 104 kB     00:00    
(4/8): tomcat-native-1.2.21-1.fc30.x86_64.rpm   165 kB/s |  74 kB     00:00    
(5/8): tomcat-servlet-4.0-api-9.0.21-1.fc30.noa 2.0 MB/s | 283 kB     00:00    
(6/8): apache-commons-daemon-1.0.15-19.fc30.x86 1.0 MB/s |  55 kB     00:00    
(7/8): tomcat-lib-9.0.21-1.fc30.noarch.rpm      4.4 MB/s | 5.2 MB     00:01    
(8/8): ecj-4.11-0.1.fc30.noarch.rpm             1.7 MB/s | 2.6 MB     00:01    
--------------------------------------------------------------------------------
Total                                           2.2 MB/s | 8.5 MB     00:03     
Executando verificação da transação
Verificação de transação completa.
Executando teste de transação
Teste de transação completo
Executando a transação
  Preparando          :                                                     1/1 
  Instalando          : tomcat-servlet-4.0-api-1:9.0.21-1.fc30.noarch       1/8 
  Executando scriptlet: tomcat-servlet-4.0-api-1:9.0.21-1.fc30.noarch       1/8 
  Instalando          : tomcat-el-3.0-api-1:9.0.21-1.fc30.noarch            2/8 
  Executando scriptlet: tomcat-el-3.0-api-1:9.0.21-1.fc30.noarch            2/8 
  Instalando          : tomcat-jsp-2.3-api-1:9.0.21-1.fc30.noarch           3/8 
  Executando scriptlet: tomcat-jsp-2.3-api-1:9.0.21-1.fc30.noarch           3/8 
  Instalando          : apache-commons-daemon-1.0.15-19.fc30.x86_64         4/8 
  Instalando          : tomcat-native-1.2.21-1.fc30.x86_64                  5/8 
  Instalando          : ecj-1:4.11-0.1.fc30.noarch                          6/8 
  Instalando          : tomcat-lib-1:9.0.21-1.fc30.noarch                   7/8 
  Executando scriptlet: tomcat-1:9.0.21-1.fc30.noarch                       8/8 
  Instalando          : tomcat-1:9.0.21-1.fc30.noarch                       8/8 
  Executando scriptlet: tomcat-1:9.0.21-1.fc30.noarch                       8/8 
  Verificando         : ecj-1:4.11-0.1.fc30.noarch                          1/8 
  Verificando         : tomcat-1:9.0.21-1.fc30.noarch                       2/8 
  Verificando         : tomcat-el-3.0-api-1:9.0.21-1.fc30.noarch            3/8 
  Verificando         : tomcat-jsp-2.3-api-1:9.0.21-1.fc30.noarch           4/8 
  Verificando         : tomcat-lib-1:9.0.21-1.fc30.noarch                   5/8 
  Verificando         : tomcat-native-1.2.21-1.fc30.x86_64                  6/8 
  Verificando         : tomcat-servlet-4.0-api-1:9.0.21-1.fc30.noarch       7/8 
  Verificando         : apache-commons-daemon-1.0.15-19.fc30.x86_64         8/8 

Instalados:
  tomcat-1:9.0.21-1.fc30.noarch                                                 
  tomcat-native-1.2.21-1.fc30.x86_64                                            
  ecj-1:4.11-0.1.fc30.noarch                                                    
  tomcat-el-3.0-api-1:9.0.21-1.fc30.noarch                                      
  tomcat-jsp-2.3-api-1:9.0.21-1.fc30.noarch                                     
  tomcat-lib-1:9.0.21-1.fc30.noarch                                             
  tomcat-servlet-4.0-api-1:9.0.21-1.fc30.noarch                                 
  apache-commons-daemon-1.0.15-19.fc30.x86_64                                   

Concluído!
$ systemctl start tomcat.service
$ systemctl status tomcat.service
● tomcat.service - Apache Tomcat Web Application Container
   Loaded: loaded (/usr/lib/systemd/system/tomcat.service; disabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Tue 2019-08-06 22:14:49 -03; 6s ago
  Process: 32123 ExecStart=/usr/libexec/tomcat/server start (code=exited, status=1/FAILURE)
 Main PID: 32123 (code=exited, status=1/FAILURE)

ago 06 22:14:49 term1 systemd[1]: Started Apache Tomcat Web Application Container.
ago 06 22:14:49 term1 server[32123]: Can't read Java functions library, aborting
ago 06 22:14:49 term1 systemd[1]: tomcat.service: Main process exited, code=exited, status=1/FAILURE
ago 06 22:14:49 term1 systemd[1]: tomcat.service: Failed with result 'exit-code'.

after confirming javapackage-tools wasn't installed and tomcat failed to start up, i installed javapackage-tools and tomcat started up fine.

Comment 7 Fedora Update System 2019-08-07 03:49:07 UTC
tomcat-9.0.21-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-cc796c2b23

Comment 8 Coty Sutherland 2019-08-07 11:54:26 UTC
In c#6 you installed tomcat-9.0.21-1 instead of tomcat-9.0.21-2 (the update including the fix) as noted in c#5. Maybe your repo cache was stale? Can you try installing again?

I verified that release 2 resolves the issue on my local machine:

~~~
$ sudo dnf install tomcat --enablerepo=updates-testing
Last metadata expiration check: 0:00:40 ago on Wed 07 Aug 2019 07:52:54 AM EDT.
Dependencies resolved.
==============================================================================================================================================================================================
 Package                                              Architecture                         Version                                        Repository                                     Size
==============================================================================================================================================================================================
Installing:
 tomcat                                               noarch                               1:9.0.21-2.fc30                                updates-testing                                90 k
Upgrading:
 tomcat-servlet-4.0-api                               noarch                               1:9.0.21-2.fc30                                updates-testing                               283 k
Installing dependencies:
 tomcat-el-3.0-api                                    noarch                               1:9.0.21-2.fc30                                updates-testing                               104 k
 tomcat-jsp-2.3-api                                   noarch                               1:9.0.21-2.fc30                                updates-testing                                64 k
 tomcat-lib                                           noarch                               1:9.0.21-2.fc30                                updates-testing                               5.2 M
 javapackages-tools                                   noarch                               5.3.0-4.fc30                                   fedora                                         33 k
Installing weak dependencies:
 tomcat-native                                        x86_64                               1.2.21-1.fc30                                  updates                                        74 k

Transaction Summary
==============================================================================================================================================================================================
Install  6 Packages
Upgrade  1 Package

Total download size: 5.9 M
~~~

Comment 9 F.Prates 2019-08-07 13:00:09 UTC
You're right Coty. Now it's working great:

$ sudo dnf install tomcat --enablerepo=updates-testing
Fedora Modular 30 - x86_64 - Updates            3.9 kB/s | 3.6 kB     00:00    
Fedora 30 - x86_64 - Test Updates                48 kB/s |  40 kB     00:00    
Fedora 30 - x86_64 - Test Updates               308 kB/s | 1.2 MB     00:04    
Fedora 30 - x86_64 - Updates                    7.9 kB/s | 3.7 kB     00:00    
Fedora 30 - x86_64 - Updates                    1.1 MB/s | 1.4 MB     00:01    
Dependências resolvidas.
================================================================================
 Package                  Arch     Version              Repository         Size
================================================================================
Instalando:
 tomcat                   noarch   1:9.0.21-2.fc30      updates-testing    90 k
Instalando dependências:
 ecj                      noarch   1:4.11-0.1.fc30      updates-testing   2.6 M
 tomcat-el-3.0-api        noarch   1:9.0.21-2.fc30      updates-testing   104 k
 tomcat-jsp-2.3-api       noarch   1:9.0.21-2.fc30      updates-testing    64 k
 tomcat-lib               noarch   1:9.0.21-2.fc30      updates-testing   5.2 M
 tomcat-servlet-4.0-api   noarch   1:9.0.21-2.fc30      updates-testing   283 k
 apache-commons-daemon    x86_64   1.0.15-19.fc30       fedora             55 k
 javapackages-tools       noarch   5.3.0-4.fc30         fedora             33 k
Instalando dependências fracas:
 tomcat-native            x86_64   1.2.21-1.fc30        updates            74 k

Resumo da transação
================================================================================
Instalar  9 Pacotes

Tamanho total do download: 8.5 M
Tamanho depois de instalado: 10 M
Correto? [s/N]: s   
Baixando pacotes:
[MIRROR] tomcat-el-3.0-api-9.0.21-2.fc30.noarch.rpm: Status code: 404 for http://mirror.upb.edu.co/fedora/linux/updates/testing/30/Everything/x86_64/Packages/t/tomcat-el-3.0-api-9.0.21-2.fc30.noarch.rpm                                   
[MIRROR] tomcat-9.0.21-2.fc30.noarch.rpm: Status code: 404 for http://mirror.upb.edu.co/fedora/linux/updates/testing/30/Everything/x86_64/Packages/t/tomcat-9.0.21-2.fc30.noarch.rpm                                                         
(1/9): tomcat-el-3.0-api-9.0.21-2.fc30.noarch.rpm                                                                                                                                                              27 kB/s | 104 kB     00:03    
[MIRROR] tomcat-jsp-2.3-api-9.0.21-2.fc30.noarch.rpm: Status code: 404 for http://mirror.upb.edu.co/fedora/linux/updates/testing/30/Everything/x86_64/Packages/t/tomcat-jsp-2.3-api-9.0.21-2.fc30.noarch.rpm                                 
(2/9): tomcat-9.0.21-2.fc30.noarch.rpm                                                                                                                                                                         22 kB/s |  90 kB     00:04    
[MIRROR] tomcat-lib-9.0.21-2.fc30.noarch.rpm: Status code: 404 for http://mirror.upb.edu.co/fedora/linux/updates/testing/30/Everything/x86_64/Packages/t/tomcat-lib-9.0.21-2.fc30.noarch.rpm                                                 
(3/9): tomcat-jsp-2.3-api-9.0.21-2.fc30.noarch.rpm                                                                                                                                                             69 kB/s |  64 kB     00:00    
(4/9): ecj-4.11-0.1.fc30.noarch.rpm                                                                                                                                                                           464 kB/s | 2.6 MB     00:05    
(5/9): tomcat-native-1.2.21-1.fc30.x86_64.rpm                                                                                                                                                                 385 kB/s |  74 kB     00:00    
(6/9): apache-commons-daemon-1.0.15-19.fc30.x86_64.rpm                                                                                                                                                        1.2 MB/s |  55 kB     00:00    
(7/9): javapackages-tools-5.3.0-4.fc30.noarch.rpm                                                                                                                                                             825 kB/s |  33 kB     00:00    
(8/9): tomcat-servlet-4.0-api-9.0.21-2.fc30.noarch.rpm                                                                                                                                                        221 kB/s | 283 kB     00:01    
(9/9): tomcat-lib-9.0.21-2.fc30.noarch.rpm                                                                                                                                                                    2.0 MB/s | 5.2 MB     00:02    
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                                                                         1.0 MB/s | 8.5 MB     00:08     
Executando verificação da transação
Verificação de transação completa.
Executando teste de transação
Teste de transação completo
Executando a transação
  Preparando          :                                                                                                                                                                                                                   1/1 
  Instalando          : tomcat-servlet-4.0-api-1:9.0.21-2.fc30.noarch                                                                                                                                                                     1/9 
  Executando scriptlet: tomcat-servlet-4.0-api-1:9.0.21-2.fc30.noarch                                                                                                                                                                     1/9 
  Instalando          : tomcat-el-3.0-api-1:9.0.21-2.fc30.noarch                                                                                                                                                                          2/9 
  Executando scriptlet: tomcat-el-3.0-api-1:9.0.21-2.fc30.noarch                                                                                                                                                                          2/9 
  Instalando          : tomcat-jsp-2.3-api-1:9.0.21-2.fc30.noarch                                                                                                                                                                         3/9 
  Executando scriptlet: tomcat-jsp-2.3-api-1:9.0.21-2.fc30.noarch                                                                                                                                                                         3/9 
  Instalando          : javapackages-tools-5.3.0-4.fc30.noarch                                                                                                                                                                            4/9 
  Instalando          : apache-commons-daemon-1.0.15-19.fc30.x86_64                                                                                                                                                                       5/9 
  Instalando          : tomcat-native-1.2.21-1.fc30.x86_64                                                                                                                                                                                6/9 
  Instalando          : ecj-1:4.11-0.1.fc30.noarch                                                                                                                                                                                        7/9 
  Instalando          : tomcat-lib-1:9.0.21-2.fc30.noarch                                                                                                                                                                                 8/9 
  Executando scriptlet: tomcat-1:9.0.21-2.fc30.noarch                                                                                                                                                                                     9/9 
  Instalando          : tomcat-1:9.0.21-2.fc30.noarch                                                                                                                                                                                     9/9 
  Executando scriptlet: tomcat-1:9.0.21-2.fc30.noarch                                                                                                                                                                                     9/9 
  Verificando         : ecj-1:4.11-0.1.fc30.noarch                                                                                                                                                                                        1/9 
  Verificando         : tomcat-1:9.0.21-2.fc30.noarch                                                                                                                                                                                     2/9 
  Verificando         : tomcat-el-3.0-api-1:9.0.21-2.fc30.noarch                                                                                                                                                                          3/9 
  Verificando         : tomcat-jsp-2.3-api-1:9.0.21-2.fc30.noarch                                                                                                                                                                         4/9 
  Verificando         : tomcat-lib-1:9.0.21-2.fc30.noarch                                                                                                                                                                                 5/9 
  Verificando         : tomcat-servlet-4.0-api-1:9.0.21-2.fc30.noarch                                                                                                                                                                     6/9 
  Verificando         : tomcat-native-1.2.21-1.fc30.x86_64                                                                                                                                                                                7/9 
  Verificando         : apache-commons-daemon-1.0.15-19.fc30.x86_64                                                                                                                                                                       8/9 
  Verificando         : javapackages-tools-5.3.0-4.fc30.noarch                                                                                                                                                                            9/9 

Instalados:
  tomcat-1:9.0.21-2.fc30.noarch           tomcat-native-1.2.21-1.fc30.x86_64                  ecj-1:4.11-0.1.fc30.noarch                        tomcat-el-3.0-api-1:9.0.21-2.fc30.noarch       tomcat-jsp-2.3-api-1:9.0.21-2.fc30.noarch      
  tomcat-lib-1:9.0.21-2.fc30.noarch       tomcat-servlet-4.0-api-1:9.0.21-2.fc30.noarch       apache-commons-daemon-1.0.15-19.fc30.x86_64       javapackages-tools-5.3.0-4.fc30.noarch        

Concluído!
$ systemctl start tomcat.service
$ systemctl status tomcat.service
● tomcat.service - Apache Tomcat Web Application Container
   Loaded: loaded (/usr/lib/systemd/system/tomcat.service; disabled; vendor preset: disabled)
   Active: active (running) since Wed 2019-08-07 09:56:09 -03; 9s ago
 Main PID: 4542 (java)
    Tasks: 51 (limit: 4915)
   Memory: 130.4M
   CGroup: /system.slice/tomcat.service
           └─4542 /usr/lib/jvm/jre/bin/java -agentpath:/usr/lib/abrt-java-connector/libabrt-java-connector.so=abrt=on, -Djavax.sql.DataSource.Factory=org.apache.commons.dbcp.BasicDataSourceFactory -classpath /usr/share/tomcat/bin/bootstr>

ago 07 09:56:10 term1 server[4542]: 07-Aug-2019 09:56:10.080 INFORMAÇÕES [main] org.apache.catalina.core.AprLifecycleListener.lifecycleEvent APR/OpenSSL configuration: useAprConnector [false], useOpenSSL [true]
ago 07 09:56:10 term1 server[4542]: 07-Aug-2019 09:56:10.083 INFORMAÇÕES [main] org.apache.catalina.core.AprLifecycleListener.initializeSSL OpenSSL successfully initialized [OpenSSL 1.1.1c FIPS  28 May 2019]
ago 07 09:56:10 term1 server[4542]: 07-Aug-2019 09:56:10.355 INFORMAÇÕES [main] org.apache.coyote.AbstractProtocol.init Initializing ProtocolHandler ["http-nio-8080"]
ago 07 09:56:10 term1 server[4542]: 07-Aug-2019 09:56:10.382 INFORMAÇÕES [main] org.apache.coyote.AbstractProtocol.init Initializing ProtocolHandler ["ajp-nio-8009"]
ago 07 09:56:10 term1 server[4542]: 07-Aug-2019 09:56:10.388 INFORMAÇÕES [main] org.apache.catalina.startup.Catalina.load Server initialization in [543] milliseconds
ago 07 09:56:10 term1 server[4542]: 07-Aug-2019 09:56:10.415 INFORMAÇÕES [main] org.apache.catalina.core.StandardService.startInternal Starting service [Catalina]
ago 07 09:56:10 term1 server[4542]: 07-Aug-2019 09:56:10.415 INFORMAÇÕES [main] org.apache.catalina.core.StandardEngine.startInternal Starting Servlet engine: [Apache Tomcat/9.0.21]
ago 07 09:56:10 term1 server[4542]: 07-Aug-2019 09:56:10.424 INFORMAÇÕES [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler ["http-nio-8080"]
ago 07 09:56:10 term1 server[4542]: 07-Aug-2019 09:56:10.443 INFORMAÇÕES [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler ["ajp-nio-8009"]
ago 07 09:56:10 term1 server[4542]: 07-Aug-2019 09:56:10.449 INFORMAÇÕES [main] org.apache.catalina.startup.Catalina.start Server startup in [60] milliseconds
lines 1-19/19 (END)

Thank you very much.

Comment 10 Fedora Update System 2019-08-15 18:09:39 UTC
tomcat-9.0.21-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2019-08-15 18:51:42 UTC
tomcat-9.0.21-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.