Bug 173079 - wireless card stops working with kernel > 2.6.12-1.1372_FC3
wireless card stops working with kernel > 2.6.12-1.1372_FC3
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
MassClosed
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-13 15:22 EST by Colin Kuskie
Modified: 2008-01-19 23:38 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-19 23:38:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Kuskie 2005-11-13 15:22:32 EST
Description of problem:

I have a wireless card:
# Atheros Communications, Inc. AR5212 802.11abg NIC

up until kernel-2.6.12-1.1372_FC3, it worked flawlessly.  With
any kernel later than that, when I plug the card in I get this
error message:

Nov  5 10:18:42 redwall kernel: cs: pcmcia_socket0: voltage interrogation timed out.

How reproducible:
Every time

Steps to Reproduce:
1. Insert card, wait for message in /var/log/messages

Expected results:
Card is detected and activated.


Additional info:
Comment 1 Colin Kuskie 2005-11-13 23:06:11 EST
After doing some googling, I added this to /etc/sysconfig/pcmcia:

CORE_OPTS="setup_delay=100"

This had no effect on the problem.

Other information:
I installed the latest kernel, 2.6.12-1.1381_FC3 and the problem still exists.

lspci shows the card:
03:00.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC
(rev 01)

but if you try to activate it via Network Device Control it says

"Device ath0 has different MAC address than expected, ignoring."
Comment 2 Pete Zaitcev 2006-01-26 23:19:36 EST
Does FC4 work?
Comment 3 Colin Kuskie 2006-01-28 23:13:22 EST
I tried the wireless card with several FC4 kernels and had no success.  However,
I haven't tried the latest one, 2.6.14-1.1656_FC4

Any other suggestions for debug?
Comment 4 Matthew Miller 2006-07-10 18:06:18 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 5 Colin Kuskie 2006-07-10 23:24:40 EDT
tried kernels:
kernel-2.6.16-1.2122_FC5
kernel-2.6.16-1.2133_FC5

under FC5 with the same results.
Comment 6 Matthew Miller 2006-07-11 14:41:13 EDT
Thanks!
Comment 7 Dave Jones 2006-10-16 14:11:06 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 8 Jon Stanley 2008-01-19 23:38:59 EST
(this is a mass-close to kernel bugs in NEEDINFO state)

As indicated previously there has been no update on the progress of this bug
therefore I am closing it as INSUFFICIENT_DATA. Please re-open if the issue
still occurs for you and I will try to assist in its resolution. Thank you for
taking the time to report the initial bug.

If you believe that this bug was closed in error, please feel free to reopen
this bug.

Note You need to log in before you can comment on or make changes to this bug.