Bug 173082 - kernel - switching to 2.6.14-1.1663_FC5 gets you "no valid vendor found in USB" errors
kernel - switching to 2.6.14-1.1663_FC5 gets you "no valid vendor found in US...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-13 16:58 EST by Michal Jaegermann
Modified: 2015-01-04 17:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-24 15:42:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2005-11-13 16:58:03 EST
Description of problem:

Attempts to get a USB device mounted on a plug-in while running
2.6.14-1.1663_FC5 succeeds once.  It appears that the reason for that is
that hfc_usb and hisax modules get loaded for some mysterious reasons and
the next attempt ends up with "hfc_usb: probe of 4-2:1.0 failed with error -5".

The above may be not really correct as apparently the first try is getting
through despite that error

Here are relevant dmesg fragments. This is the first attempt to mount
a USB floppy:

usb 5-1: new full speed USB device using uhci_hcd and address 2
HFC-S USB: probing interface(0) actalt(0) minor(0)
HFC-S USB: no valid vendor found in USB descriptor
hfc_usb: probe of 5-1:1.0 failed with error -5
Initializing USB Mass Storage driver...
scsi2 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
  Vendor: SONY      Model: USB-FDU           Rev: 5.01
  Type:   Direct-Access                      ANSI SCSI revision: 00
SCSI device sdb: 1440 512-byte hdwr sectors (1 MB)
sdb: Write Protect is on
sdb: Mode Sense: 00 46 1e 80
sdb: assuming drive cache: write through
SCSI device sdb: 1440 512-byte hdwr sectors (1 MB)
sdb: Write Protect is on
sdb: Mode Sense: 00 46 1e 80
sdb: assuming drive cache: write through
 sdb: unknown partition table
sd 2:0:0:0: Attached scsi removable disk sdb
usb-storage: device scan complete
....

and we are fine.  All subsequent attempts end up like that:

usb 5-1: new full speed USB device using uhci_hcd and address 3
HFC-S USB: probing interface(0) actalt(0) minor(0)
HFC-S USB: no valid vendor found in USB descriptor
hfc_usb: probe of 5-1:1.0 failed with error -5

and that is it.  Unless I will do 'modprobe -r hfc_usb hisax' and then
I see:

usb 4-2: new full speed USB device using uhci_hcd and address 3
scsi3 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 3
usb-storage: waiting for device to settle before scanning
CSLIP: code copyright 1989 Regents of the University of California
ISDN subsystem Rev: 1.1.2.3/1.1.2.3/1.1.2.2/1.1.2.3/1.1.2.2/1.1.2.2 loaded
HiSax: Linux Driver for passive ISDN cards
HiSax: Version 3.5 (module)
HiSax: Layer1 Revision 2.46.2.5
HiSax: Layer2 Revision 2.30.2.4
HiSax: TeiMgr Revision 2.20.2.3
HiSax: Layer3 Revision 2.22.2.3
HiSax: LinkLayer Revision 2.59.2.4
HFC-S USB: driver module revision 4.36 date 2005/04/08 loaded, (debug=-1)
usbcore: registered new driver hfc_usb
  Vendor: SONY      Model: USB-FDU           Rev: 5.01
  Type:   Direct-Access                      ANSI SCSI revision: 00
SCSI device sdb: 1440 512-byte hdwr sectors (1 MB)
sdb: Write Protect is on
sdb: Mode Sense: 00 46 1e 80
sdb: assuming drive cache: write through
SCSI device sdb: 1440 512-byte hdwr sectors (1 MB)
sdb: Write Protect is on
sdb: Mode Sense: 00 46 1e 80
sdb: assuming drive cache: write through
 sdb: unknown partition table
sd 3:0:0:0: Attached scsi removable disk sdb
usb-storage: device scan complete

and in this moment I am fine again - for one try.

It looks like I may workaround the issue by adding in /etc/modprobe.conf

install hfc_usb :
install hisax :

lines, and then repluging a USB device gets it mounted again, but
I may need hfc_usb (I don't) and also when runnig 2.6.14-1.1644_FC5
in exactly the same configuration of everything else I do not need such
shenanigans and things do work as expected (and hfc_usb is not getting unduly
loaded).

Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1663_FC5

How reproducible:
always
Comment 1 Zuirdj 2005-11-13 19:39:31 EST
I think I can't boot since 2.6.14-1.1632_FC5 due this bug. When system is
activating "storage... network.... sound", above message appears and doesn't rhgb.
Comment 2 Michal Jaegermann 2005-11-14 02:31:31 EST
> I think I can't boot since 2.6.14-1.1632_FC5 
I have not seen that with kernels earlier than reported although I did
not try every single one.  If this is really the same issue than a workaround
I mentioned may work for you. You may possibly need new initrd images.
Comment 3 Dave Jones 2005-12-23 23:20:08 EST
a bug was fixed in hfc-usb a while ago, can you confirm that the current builds
work for you ?
Comment 4 Michal Jaegermann 2005-12-24 01:08:15 EST
I did not see that particular problem for a while.  Automatical mounting
of USB devices currently does not work for me at all but this looks like
a user-space issue.  On the top of it after recent updates gnome-vfs bombs
out but root can mount USB devices from a command line.
Comment 5 Dave Jones 2005-12-24 15:42:12 EST
ok, as the hfc bug is fixed , I'll close this.
The auto-mounting problem should probably be filed against gnome-volume-manager

Note You need to log in before you can comment on or make changes to this bug.