Bug 173096 - mysqldump output missing auto-increment value.
mysqldump output missing auto-increment value.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-13 23:01 EST by Rodd Clarkson
Modified: 2013-07-02 23:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-09 18:43:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodd Clarkson 2005-11-13 23:01:59 EST
Description of problem:

I've dumped a database from mysql-5.0.15-2 using the following command:

DROP TABLE IF EXISTS `tblContents`;
CREATE TABLE `tblContents` (
  `intContentID` int(11) NOT NULL auto_increment,
  `strTitle` varchar(150) default NULL,
  `chrStatus` char(3) default NULL,
  `intParent` int(11) default NULL,
  `intOrder` int(11) default NULL,
  `strGroups` text,
  `dtPosted` datetime default NULL,
  `strAccess` text,
  `dtActivate` datetime default NULL,
  `dtDeactivate` datetime default NULL,
  `intShortList` int(11) default NULL,
  `strShortListTitle` varchar(80) default NULL,
  `strTextLink` varchar(100) default NULL,
  `strType` varchar(100) default 'content',
  `strExtraLink` varchar(255) default NULL,
  `strTimeStamp` timestamp NOT NULL default CURRENT_TIMESTAMP on update
CURRENT_TIMESTAMP,
  `dtTimeStamp` timestamp NOT NULL default '0000-00-00 00:00:00',
  PRIMARY KEY  (`intContentID`)
) ENGINE=MyISAM DEFAULT CHARSET=latin1;



Notice the follow:

intContentID has no auto_increment option in test.sql output.
strTimeStamp is different
there is no DEFAULT CHARSET=latin1 in the test.sql output.


Version-Release number of selected component (if applicable):

mysqlclient14-4.1.14-1
mysqlclient10-3.23.58-6
mysql-5.0.15-2
mysql-server-5.0.15-2
Comment 1 Tom Lane 2005-11-14 00:14:29 EST
Hmm ... unless you have evidence to suggest that this is specific to Red Hat's packaging of MySQL, you 
should probably be filing the problem upstream at www.mysql.com.
Comment 2 Rodd Clarkson 2005-11-14 17:30:50 EST
Ah, sorry.

I can't say that this is unique to rawhide, but usually bugs like this (as far
as I've seen) are just refered on to the various bug databases.

I've filed it upstream at: http://bugs.mysql.com/14929
Comment 3 Rodd Clarkson 2005-11-14 17:36:06 EST
Also, there's a whole lot of missing comment from my original bug report. 
(mmmm, but in firefox, because it was there, but I digress).

I'm going to refile the description of the problem in it's entirity.

I've dumped a database from mysql-5.0.15-2 using the following command:

DROP TABLE IF EXISTS `tblContents`;
CREATE TABLE `tblContents` (
  `intContentID` int(11) NOT NULL auto_increment,
  `strTitle` varchar(150) default NULL,
  `chrStatus` char(3) default NULL,
  `intParent` int(11) default NULL,
  `intOrder` int(11) default NULL,
  `strGroups` text,
  `dtPosted` datetime default NULL,
  `strAccess` text,
  `dtActivate` datetime default NULL,
  `dtDeactivate` datetime default NULL,
  `intShortList` int(11) default NULL,
  `strShortListTitle` varchar(80) default NULL,
  `strTextLink` varchar(100) default NULL,
  `strType` varchar(100) default 'content',
  `strExtraLink` varchar(255) default NULL,
  `strTimeStamp` timestamp NOT NULL default CURRENT_TIMESTAMP on update
CURRENT_TIMESTAMP,
  `dtTimeStamp` timestamp NOT NULL default '0000-00-00 00:00:00',
  PRIMARY KEY  (`intContentID`)
) ENGINE=MyISAM DEFAULT CHARSET=latin1;


A snip of the output in test.sql shows:

DROP TABLE IF EXISTS `tblContents`;
CREATE TABLE `tblContents` (
  `intContentID` int(11) NOT NULL,
  `strTitle` varchar(150) default NULL,
  `chrStatus` char(3) default NULL,
  `intParent` int(11) default NULL,
  `intOrder` int(11) default NULL,
  `strGroups` text,
  `dtPosted` datetime default NULL,
  `strAccess` text,
  `dtActivate` datetime default NULL,
  `dtDeactivate` datetime default NULL,
  `intShortList` int(11) default NULL,
  `strShortListTitle` varchar(80) default NULL,
  `strTextLink` varchar(100) default NULL,
  `strType` varchar(100) default 'content',
  `strExtraLink` varchar(255) default NULL,
  `strTimeStamp` timestamp NOT NULL,
  `dtTimeStamp` timestamp NOT NULL default '0000-00-00 00:00:00',
  PRIMARY KEY  (`intContentID`)
) TYPE=MyISAM;


A snip from the output of a dump from the same database using mysql-4.1 shows:

DROP TABLE IF EXISTS `tblContents`;
CREATE TABLE `tblContents` (
  `intContentID` int(11) NOT NULL auto_increment,
  `strTitle` varchar(150) default NULL,
  `chrStatus` char(3) default NULL,
  `intParent` int(11) default NULL,
  `intOrder` int(11) default NULL,
  `strGroups` text,
  `dtPosted` datetime default NULL,
  `strAccess` text,
  `dtActivate` datetime default NULL,
  `dtDeactivate` datetime default NULL,
  `intShortList` int(11) default NULL,
  `strShortListTitle` varchar(80) default NULL,
  `strTextLink` varchar(100) default NULL,
  `strType` varchar(100) default 'content',
  `strExtraLink` varchar(255) default NULL,
  `strTimeStamp` timestamp NOT NULL default CURRENT_TIMESTAMP on update
CURRENT_TIMESTAMP,
  `dtTimeStamp` timestamp NOT NULL default '0000-00-00 00:00:00',
  PRIMARY KEY  (`intContentID`)
) ENGINE=MyISAM DEFAULT CHARSET=latin1;


Notice the follow:

intContentID has no auto_increment option in test.sql output.
strTimeStamp is different
there is no DEFAULT CHARSET=latin1 in the test.sql output.

Version-Release number of selected component (if applicable):

mysqlclient14-4.1.14-1
mysqlclient10-3.23.58-6
mysql-5.0.15-2
mysql-server-5.0.15-2
Comment 4 Tom Lane 2005-12-09 18:43:14 EST
Closing this bz entry since it's been filed with upstream (who seem to think
it's not a bug anyway).

Note You need to log in before you can comment on or make changes to this bug.