This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 173114 - Failed to change context of /etc/selinux/targeted/...
Failed to change context of /etc/selinux/targeted/...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-14 04:52 EST by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-26 19:39:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2005-11-14 04:52:56 EST
Description of problem:
While re-installing the latest policy (e.g. rpm -Uvh --force) after loading it 
before, you get the following errors:

install: warning: failed to change context of /etc/selinux/targeted/users/
system.users to system_u:object_r:selinux_config_t: Keine Berechtigung
install: warning: failed to change context of /etc/selinux/targeted/contexts/
customizable_types to system_u:object_r:default_context_t: Keine Berechtigung
install: warning: failed to change context of /etc/selinux/targeted/contexts/
port_types to system_u:object_r:default_context_t: Keine Berechtigung
install: warning: failed to change context of /etc/selinux/targeted/contexts/
files/homedir_template to system_u:object_r:file_context_t: Keine Berechtigung
install: warning: failed to change context of /etc/selinux/targeted/contexts/
files/file_contexts to system_u:object_r:file_context_t: Keine Berechtigung

Audit log:
type=AVC msg=audit(1131738954.240:1768): avc:  denied  { relabelto } for  
pid=18412 comm="install" name="system.users" dev=cciss/c0d0p2 ino=262282 
scontext=root:system_r:rpm_script_t:s0-s0:c0.c255 tcontext=system_u:object_r:
selinux_config_t:s0 tclass=file
type=AVC msg=audit(1131738954.420:1769): avc:  denied  { relabelto } for  
pid=18418 comm="install" name="customizable_types" dev=cciss/c0d0p2 ino=262650 
scontext=root:system_r:rpm_script_t:s0-s0:c0.c255 tcontext=system_u:object_r:
default_context_t:s0 tclass=file
type=AVC msg=audit(1131738954.572:1770): avc:  denied  { relabelto } for  
pid=18424 comm="install" name="port_types" dev=cciss/c0d0p2 ino=262678 
scontext=root:system_r:rpm_script_t:s0-s0:c0.c255 tcontext=system_u:object_r:
default_context_t:s0 tclass=file
type=AVC msg=audit(1131738954.716:1771): avc:  denied  { relabelto } for  
pid=18427 comm="install" name="homedir_template" dev=cciss/c0d0p2 ino=262769 
scontext=root:system_r:rpm_script_t:s0-s0:c0.c255 tcontext=system_u:object_r:
file_context_t:s0 tclass=file
type=AVC msg=audit(1131738954.856:1772): avc:  denied  { relabelto } for  
pid=18428 comm="install" name="file_contexts" dev=cciss/c0d0p2 ino=262657 
scontext=root:system_r:rpm_script_t:s0-s0:c0.c255 tcontext=system_u:object_r:
file_context_t:s0 tclass=file

Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.27.2-19

How reproducible:
Everytime, as described.

Actual results:
Errors.

Expected results:
No errors.
Comment 1 Robert Scheck 2005-11-26 19:39:37 EST
Since selinux-policy-2.0.0-1, I can't reproduce the problem. This doesn't mean, 
that the problem is fixed in 1.27.X, but Fedora Core Development switched to 
serefpolicy, closing now.

Note You need to log in before you can comment on or make changes to this bug.