Bug 173145 - Kernel 2.6.14-1.1637 does not boot on HP ML-350 G4
Kernel 2.6.14-1.1637 does not boot on HP ML-350 G4
Status: CLOSED DUPLICATE of bug 169610
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-14 11:58 EST by Michael Ditum
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-14 14:42:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Ditum 2005-11-14 11:58:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5

Description of problem:
I am trying to upgrade to the 2.6.14, this is from a clean minimal FC4 install. All I have updated is the kernel to 2.6.14-1.1637. Upon booting the system I get a Kernel Panic saying its not syncing. Earlier in the booting it states that "No Volume Groups Found"

I get the same problem with kernel-2.6.14-1.1639_FC4.i586.rpm from testing...

Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1637

How reproducible:
Always

Steps to Reproduce:
1. Install FC4 on HP ML350-G4
2. Install 2.6.14-1637 kernel
3. Reboot
  

Actual Results:  Booting 'Fedora Core (2.6.14-1.1637_FC4)'

root(hd0,0)
  FileSystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.14-1.1637_FC4 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
    [Linux-bzImage, setup=0x1e00, size=0x19d9ac]
initrd /initrd--2.6.14-1.1637_FC4.img
    [Linux-initrd @ 0x1def5000, 0x10d3a0 bytes]

Uncompressing Linux... Ok, booting the kernel
PCI: Cannot allocate resource region 4 of device 0000:00:1d.0
PCI: Cannot allocate resource region 4 of device 0000:00:1d.1

pnp: Unable to assign resources to device 00:08
RedHat nash version 4.2.15 starting
    Reading all physical volumes. This may take a while...
    No volume groups found
    Unable to find volume group "VolGroup00"
ERROR: /bin/lvm exited abnormally with value 5 (pid 366)
mount: error 6 mounting ext3
ERROR opening /dev/console!!!!: 2
error dup2'ing fd of 0 to 0
error dup2'ing fd of 0 to 1
error dup2'ing fd of 0 to 2
switchroot: mount failed: 22
Kernel panic - not syncing. Attempting to kill init!

Expected Results:  System boots normally

Additional info:

The server is an HP Proliant ML350-G4 (http://h10010.www1.hp.com/wwpc/uk/en/sm/WF25a/521-525-358265-358265-12083545-12175812.html) which has a (form lspci) LSI Logic / Symbios Logic 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI, which under 2.6.11 is modules... mptscsih & mptbase.

lspci (on 2.6.11) gives...
00:00.0 Host bridge: Intel Corporation E7520 Memory Controller Hub (rev 0c)
00:02.0 PCI bridge: Intel Corporation E7525/E7520/E7320 PCI Express Port A (rev 0c)
00:04.0 PCI bridge: Intel Corporation E7525/E7520 PCI Express Port B (rev 0c)
00:06.0 PCI bridge: Intel Corporation E7520 PCI Express Port C (rev 0c)
00:1c.0 PCI bridge: Intel Corporation 6300ESB 64-bit PCI-X Bridge (rev 02)
00:1d.0 USB Controller: Intel Corporation 6300ESB USB Universal Host Controller (rev 02)
00:1d.1 USB Controller: Intel Corporation 6300ESB USB Universal Host Controller (rev 02)
00:1d.4 System peripheral: Intel Corporation 6300ESB Watchdog Timer (rev 02)
00:1d.5 PIC: Intel Corporation 6300ESB I/O Advanced Programmable Interrupt Controller (rev 02)
00:1d.7 USB Controller: Intel Corporation 6300ESB USB2 Enhanced Host Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 0a)
00:1f.0 ISA bridge: Intel Corporation 6300ESB LPC Interface Controller (rev 02)
00:1f.1 IDE interface: Intel Corporation 6300ESB PATA Storage Controller (rev 02)
01:02.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5705_2 Gigabit Ethernet (rev 03)
01:03.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)
01:04.0 System peripheral: Compaq Computer Corporation: Unknown device 00d7 (rev 01)
02:02.0 Multimedia video controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
02:02.2 Multimedia controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder [MPEG Port] (rev 05)
02:02.4 Multimedia controller: Conexant: Unknown device 8804 (rev 05)
02:03.0 SCSI storage controller: LSI Logic / Symbios Logic 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI (rev 08)
02:03.1 SCSI storage controller: LSI Logic / Symbios Logic 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI (rev 08)
05:00.0 PCI bridge: Intel Corporation 6700PXH PCI Express-to-PCI Bridge A (rev 09)
05:00.2 PCI bridge: Intel Corporation 6700PXH PCI Express-to-PCI Bridge B (rev 09)
06:01.0 Multimedia video controller: Internext Compression Inc iTVC16 (CX23416) MPEG-2 Encoder (rev 01)
09:01.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
09:02.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
Comment 1 Dave Jones 2005-11-14 14:42:00 EST

*** This bug has been marked as a duplicate of 169610 ***

Note You need to log in before you can comment on or make changes to this bug.