Bug 1731753 - SELinux is preventing journalctl from 'search' accesses on the directory 1.
Summary: SELinux is preventing journalctl from 'search' accesses on the directory 1.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 30
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b2354c590ed8d0122f4f3acc38f...
: 1783647 1783794 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-21 18:40 UTC by Mehmet Andac
Modified: 2020-01-31 01:12 UTC (History)
8 users (show)

Fixed In Version: selinux-policy-3.14.3-55.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 01:12:19 UTC


Attachments (Terms of Use)

Description Mehmet Andac 2019-07-21 18:40:57 UTC
Description of problem:
SELinux is preventing journalctl from 'search' accesses on the directory 1.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that journalctl should be allowed search access on the 1 directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'journalctl' --raw | audit2allow -M my-journalctl
# semodule -X 300 -i my-journalctl.pp

Additional Information:
Source Context                system_u:system_r:journalctl_t:s0
Target Context                system_u:system_r:init_t:s0
Target Objects                1 [ dir ]
Source                        journalctl
Source Path                   journalctl
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.3-40.fc30.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.1.18-300.fc30.x86_64 #1 SMP Mon
                              Jul 15 15:42:34 UTC 2019 x86_64 x86_64
Alert Count                   20
First Seen                    2019-07-21 19:23:22 +03
Last Seen                     2019-07-21 19:29:17 +03
Local ID                      5fddfb82-3851-453a-87c0-8046578e70ff

Raw Audit Messages
type=AVC msg=audit(1563726557.806:293): avc:  denied  { search } for  pid=5373 comm="journalctl" name="1" dev="proc" ino=14215 scontext=system_u:system_r:journalctl_t:s0 tcontext=system_u:system_r:init_t:s0 tclass=dir permissive=0


Hash: journalctl,journalctl_t,init_t,dir,search

Version-Release number of selected component:
selinux-policy-3.14.3-40.fc30.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.10.1
hashmarkername: setroubleshoot
kernel:         5.1.18-300.fc30.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2019-07-23 14:19:18 UTC
Hi Mehmet, 

Are you able reproduce this issue? Do you know when this happened? Is something broken on your system? 

Thanks,
Lukas.

Comment 2 Quint Guvernator 2019-09-03 09:54:28 UTC
Description of problem:
Install snapd and run `snap install lxd`.

Version-Release number of selected component:
selinux-policy-3.14.3-43.fc30.noarch

Additional info:
reporter:       libreport-2.10.1
hashmarkername: setroubleshoot
kernel:         5.2.9-200.fc30.x86_64
type:           libreport

Comment 3 Lukas Vrabec 2019-12-15 15:47:10 UTC
*** Bug 1783647 has been marked as a duplicate of this bug. ***

Comment 4 Zdenek Pytela 2019-12-16 08:07:50 UTC
*** Bug 1783794 has been marked as a duplicate of this bug. ***

Comment 6 Lukas Vrabec 2019-12-16 09:56:29 UTC
commit 3a268ba2d49cc2d15e865494291ed51565e65dc8 (HEAD -> rawhide, origin/rawhide, origin/HEAD)
Author: Zdenek Pytela <zpytela@redhat.com>
Date:   Mon Dec 16 09:23:25 2019 +0100

    Allow journalctl read init state BZ(1731753)

Comment 7 Fedora Update System 2019-12-28 18:43:12 UTC
FEDORA-2019-6f872cd95f has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-6f872cd95f

Comment 8 Fedora Update System 2020-01-04 21:17:56 UTC
selinux-policy-3.14.3-54.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-6f872cd95f

Comment 9 Fedora Update System 2020-01-14 02:48:24 UTC
selinux-policy-3.14.3-55.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-384545235e

Comment 10 Fedora Update System 2020-01-31 01:12:19 UTC
selinux-policy-3.14.3-55.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.