Bug 1731842 - kubefed operator installation status is "Copied", should be "InstallSucceeded"
Summary: kubefed operator installation status is "Copied", should be "InstallSucceeded"
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Federation
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.2.0
Assignee: Paul Morie
QA Contact: Qin Ping
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-22 07:58 UTC by Qin Ping
Modified: 2019-07-23 01:42 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-23 01:42:47 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Qin Ping 2019-07-22 07:58:05 UTC
Description of problem:
Install kubefed operator from web console, kubefed operator installed successfully, but the status in the Operator->installed Operators page is "Copied", it should be "InstallSucceeded".

Version-Release number of selected component (if applicable):
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.2.0-0.nightly-2019-07-21-222447   True        False         3h40m   Cluster version is 4.2.0-0.nightly-2019-07-21-222447

kubefed-operator: 0.1.0


How reproducible:
100%


Steps to Reproduce:
1. Log into OCP web console with kubeadmin user
2. Create a namespace federation-system (Home->Projects->Create Project)
3. Install kubefed operator from OperatorHub(Operators->OperatorHub)
4. Check operator installation(Operators->Installed Operators)

Actual results:
Status is "Copied"	

Expected results:
Status is "InstallSucceeded".

Additional info:


Note You need to log in before you can comment on or make changes to this bug.