Bug 1731848 - The provided APIs in kubefed-operator operator details information are not the real APIs provided by kubefed operator
Summary: The provided APIs in kubefed-operator operator details information are not th...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Federation
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.2.0
Assignee: Aniket Bhat
QA Contact: Qin Ping
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-22 08:17 UTC by Qin Ping
Modified: 2019-07-30 18:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-30 18:06:10 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Qin Ping 2019-07-22 08:17:39 UTC
Description of problem:
After the kubefed operator is deployed successfully, we can check the detailed information about the kubefed operator. Now, kubefed-operator's Provided APIs includes a lot of APIs which are the APIs provided by kubefed. Such as, ClusterPropagatedVersion, DNSEndpoint, ...


Version-Release number of selected component (if applicable):
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.2.0-0.nightly-2019-07-21-222447   True        False         3h40m   Cluster version is 4.2.0-0.nightly-2019-07-21-222447

kubefed-operator: 0.1.0


How reproducible:
100%


Steps to Reproduce:
1. Log into OCP web console with kubeadmin user
2. Create a namespace federation-system (Home->Projects->Create Project)
3. Install kubefed operator from OperatorHub(Operators->OperatorHub)
4. Check operator installation(Operators->Installed Operators->Kubefed Operator->Provided APIs)

Actual results:
There are 12 APIs, actually, only "KubeFed" API is provided by kubefed operator.


Expected results:


Additional info:


Note You need to log in before you can comment on or make changes to this bug.