Bug 1731883 - Unable to install metrics VM on rhev - metrics-store-installer VM doesnt got created
Summary: Unable to install metrics VM on rhev - metrics-store-installer VM doesnt got ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine-metrics
Classification: oVirt
Component: Generic
Version: 1.2.0.1
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ovirt-4.3.5-1
: ---
Assignee: Shirly Radco
QA Contact: Ivana Saranova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-22 09:27 UTC by Evgeny Slutsky
Modified: 2019-07-31 10:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-31 10:57:54 UTC
oVirt Team: Metrics


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github ansible ansible pull 59196 None None None 2019-07-22 09:30:35 UTC
Github ansible ansible pull 59286 None None None 2019-07-22 12:36:06 UTC
Github oVirt ovirt-ansible-vm-infra issues 104 None None None 2019-07-22 09:27:42 UTC

Description Evgeny Slutsky 2019-07-22 09:27:16 UTC
when running metrics installation from engine:
ANSIBLE_JINJA2_EXTENSIONS="jinja2.ext.do" ./configure_ovirt_machines_for_metrics.sh   --playbook=ovirt-metrics-store-installation.yml

2019-07-14 09:48:03,868 p=10844 u=root | Using module file /usr/lib/python2.7/site-packages/ansible/modules/utilities/logic/async_status.py
2019-07-14 09:48:04,026 p=10844 u=root | The full traceback is:
Traceback (most recent call last):
File "/tmp/ansible_ovirt_vm_payload_txFuqn/main.py", line 2071, in main
) else None,
File "/tmp/ansible_ovirt_vm_payload_txFuqn/ansible_ovirt_vm_payload.zip/ansible/module_utils/ovirt.py", line 738, in action
getattr(entity_service, action)(**kwargs)
File "/usr/lib64/python2.7/site-packages/ovirtsdk4/services.py", line 31504, in start
return self._internal_action(action, 'start', None, headers, query, wait)
File "/usr/lib64/python2.7/site-packages/ovirtsdk4/service.py", line 299, in _internal_action
return future.wait() if wait else future
File "/usr/lib64/python2.7/site-packages/ovirtsdk4/service.py", line 55, in wait
return self._code(response)
File "/usr/lib64/python2.7/site-packages/ovirtsdk4/service.py", line 296, in callback
self._check_fault(response)
File "/usr/lib64/python2.7/site-packages/ovirtsdk4/service.py", line 132, in _check_fault
self._raise_error(response, body)
File "/usr/lib64/python2.7/site-packages/ovirtsdk4/service.py", line 118, in _raise_error
raise error
Error: Fault reason is "Cannot use sysprep and cloud_init tags simultaneously when running VM.". HTTP response code is 409.



Version-Release number of selected component (if applicable):
ansible-2.8.1-1.el7.noarch
ovirt-ansible-vm-infra-1.1.20-1.el7.noarch
ovirt-ansible-roles-1.1.7-1.el7.noarch
ovirt-engine-metrics-1.3.4-0.0.master.20190714091448.git97f3dea.el7.noarch
python-ovirt-engine-sdk4-4.3.2-2.20190703git231d55c.el7.x86_64



How reproducible:


Steps to Reproduce:
1. Install Engine + Host 4.3.4
2. run metrics deployment from engine


Actual results:
VM Installation failed

Expected results:
VM Installation completed

Comment 1 Evgeny Slutsky 2019-07-22 09:33:16 UTC
please update

Comment 2 Martin Perina 2019-07-23 07:39:23 UTC
Both github patches were merged and they will be available as a part of Ansible 2.8.3, so moving to MODIFIED

Comment 3 Ivana Saranova 2019-07-26 10:25:50 UTC
Steps:
1) Install metrics store according to the documentation
2) Check that first playbook ran without errors

Result:
Playbook ended successfully, no errors. Metrics store was successfully installed.

Verified in:
ovirt-engine-4.3.5.4-0.1.el7.noarch
ovirt-engine-metrics-1.3.3.2-1.el7ev.noarch
ansible-2.8.2-1.201907241649git.42c2b3e496.el7.ans.noarch

Comment 4 Sandro Bonazzola 2019-07-31 10:57:54 UTC
This bugzilla is included in oVirt 4.3.5 first async release, published on July 31th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.5 first async release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.