Bug 1731894 - [rados] - error message when min_size is set to 2 and size to 1 needs to be tuned
Summary: [rados] - error message when min_size is set to 2 and size to 1 needs to be t...
Keywords:
Status: NEW
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS
Version: 3.3
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 4.*
Assignee: Neha Ojha
QA Contact: Manohar Murthy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-22 10:17 UTC by Vasishta
Modified: 2020-02-19 02:24 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 40910 None None None 2019-07-23 20:11:16 UTC

Description Vasishta 2019-07-22 10:17:24 UTC
Description of problem:
When min_size of the pool was set to 2 by mistake when size was just 1, the error message says 'min_size must be between 1 and 1' which needs to be tuned.

Version-Release number of selected component (if applicable):
12.2.12-40.el7cp

How reproducible:
Always

Steps to Reproduce:
1. create a pool
2. reduce the size of the pool to 1
3. try to increase the min_size of the pool to 2

Actual results:
Error EINVAL: pool min_size must be between 1 and 1

Expected results:
Message should convey that
the range of min_size is from 1 to 'size'

Comment 2 Vasishta 2019-07-23 04:45:41 UTC
I presume from [1] that for replicated pool the output would be 
'pool min_size must be between 1 and size, which is set to 1'


[1] https://github.com/ceph/ceph/pull/29184/files#diff-0a5db46a44ae9900e226289a810f10e8R7461

Comment 3 Giridhar Ramaraju 2019-08-05 13:08:35 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 4 Giridhar Ramaraju 2019-08-05 13:10:01 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 5 Josh Durgin 2019-08-21 22:30:07 UTC
Moving out of 3.3z1 due to low severity


Note You need to log in before you can comment on or make changes to this bug.