Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1731916 - This package is part of rhel7. Remove from epel7
Summary: This package is part of rhel7. Remove from epel7
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-boto3
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Charalampos Stratakis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-22 11:40 UTC by Tuomo Soini
Modified: 2019-12-09 23:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-09 23:08:30 UTC
Type: Bug


Attachments (Terms of Use)

Description Tuomo Soini 2019-07-22 11:40:25 UTC
python2-boto3-1.4.6-1.el7 is accidentally installed into epel7 build root instead of python-boto3-1.4.6-5.el7 which is distro packages.

This causes successful build of python-certbot-dns-route53 which should fail because of invalid dependencies. That is caused by differences of python2-boto3 packages compared to rhel7 distro package. Please drop package, it is against epel7 policy. If limited arch package is required, it should be identical to rhel7 one but with release number starting with 0.

Comment 1 Charalampos Stratakis 2019-10-30 17:26:53 UTC
It seems the package is part of the rhel high availability repository.

Is there a policy in place related to that repository and the EPEL availability of a package?

Comment 2 Chris Feist 2019-11-05 21:21:40 UTC
I believe the policy is that two packages with the same name can't be in both repositories (or there can be issues with versioning).

Comment 3 Charalampos Stratakis 2019-12-09 23:08:30 UTC
The package has been retired.


Note You need to log in before you can comment on or make changes to this bug.