Bug 173202 - CONFIG_DEBUG_INFO=y by default
CONFIG_DEBUG_INFO=y by default
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-14 17:02 EST by Jean Blouin
Modified: 2015-01-04 17:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-14 23:17:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean Blouin 2005-11-14 17:02:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.10) Gecko/20050719 Red Hat/1.0.6-1.4.1 Firefox/1.0.6

Description of problem:
The default config file sets

the following config options:

CONFIG_DEBUG_INFO=y
and 
CONFIG_CC_OPTIMIZE_FOR_SIZE=y

this ends up compiling most of the files with 
-g -Os

wouldn't it be preferable for performance to compile with both this options unsetted? Than the code would be compiled with -O2?


Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-22.EL

How reproducible:
Always

Steps to Reproduce:
1.compile the kernel with make bzImage V=1
2.see that most files are compiled with -g -Os
3.
  

Actual Results:  most kernel files are compiled with -g -Os

Expected Results:  if you unsetted the CONFIG_DEBUG_INFO and the CONFIG_CC_OPTIMIZE_FOR_SIZE
then most file will be compile with -O2

Additional info:
Comment 1 Dave Jones 2005-11-14 23:17:06 EST
debug info is set so that the debugging info can get stripped out to the
-debuginfo rpms.

-Os is used because cache footprint is more important on modern processors than
microoptimisations.

Note You need to log in before you can comment on or make changes to this bug.