This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 173215 - Switching to virtual console then back to x causes display corruption
Switching to virtual console then back to x causes display corruption
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-14 21:16 EST by Aaron Gaudio
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-14 13:11:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
X11 log file. Note the log file doesn't change between switching away and back to X. (58.21 KB, text/plain)
2005-11-14 21:16 EST, Aaron Gaudio
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 5795 None None None Never

  None (edit)
Description Aaron Gaudio 2005-11-14 21:16:23 EST
Description of problem:
I have a Sony Vaio laptop with an Intel i830 video card.

gdm/X starts up fine at boot. When I switch to a virtual console, I get a prompt
as expected. However, when I attempt to switch back to X, the display locks up,
still showing the virtual console, but then the screen turns white, as if it's
melting. Luckily the screen does not seem to suffer any permanent effects. I can
still Cntl-Alt-Delete in order to restart.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-37.FC4.49.2

How reproducible:
Always

Steps to Reproduce:
1. Start up in graphical mode.
2. Switch to a virtual terminal (Ctl-Alt-Fn or chvt n, where 1 <= n <=6)
3. Switch back to the X console (Alt-F7 or chvt 7)
  
Actual results:
Display locks up, begins to turn white (in a pattern remiscent of melting).

Expected results:
Display correctly switches back to X console.

Additional info:
I've tried this with the following kernels (all with the same result):
kernel-2.6.11-1.1369_FC4
kernel-2.6.14-1.1637_FC4
vanilla 2.6.14 + suspend2 patch, with full pre-empt enabled
Comment 1 Aaron Gaudio 2005-11-14 21:16:23 EST
Created attachment 121041 [details]
X11 log file. Note the log file doesn't change between switching away and back to X.
Comment 2 Aaron Gaudio 2006-02-14 21:55:25 EST
I just tried downgrading the following packages to their FC4 original versions:
xorg-x11-6.8.2-31.i386.rpm
xorg-x11-libs-6.8.2-31.i386.rpm
xorg-x11-Mesa-libGL-6.8.2-31.i386.rpm
xorg-x11-Mesa-libGLU-6.8.2-31.i386.rpm
xorg-x11-xfs-6.8.2-31.i386.rpm

Lo, now when I switch to the console I get nothing but a blank screen, but I can
switch back to X without any problems (which also has the benefit of allowing me
to use suspend2 to suspend to disk and resume to X).

So, I think this is pretty strong evidence that there is something amiss with
the recent versions of xorg-x11 and the i830 drivers.
Comment 3 Mike A. Harris 2006-03-08 05:38:22 EST
If this issue turns out to still be reproduceable in the latest
updates for this Fedora Core release, please file a bug report
in the X.Org bugzilla located at http://bugs.freedesktop.org in
the "xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", and awaiting upstream
bug report URL for tracking.

Thanks in advance.
Comment 4 Aaron Gaudio 2006-04-30 23:57:13 EDT
Sorry for the long lag, but I have only recently upgraded xorg along with FC5. I
have the latest FC5 updates, and the problem is back. I have found a bug which
may be the same thing at freedesktop.org:
https://bugs.freedesktop.org/show_bug.cgi?id=5795
Comment 5 Mike A. Harris 2006-06-14 13:11:06 EDT
Thanks, tracking in xorg bugzilla now.

Note You need to log in before you can comment on or make changes to this bug.