Bug 1732297 - Symbolic links /usr/bin/miniterm-3.7.py and /usr/bin/miniterm-2.7.py are broken
Summary: Symbolic links /usr/bin/miniterm-3.7.py and /usr/bin/miniterm-2.7.py are broken
Keywords:
Status: CLOSED DUPLICATE of bug 1421373
Alias: None
Product: Fedora
Classification: Fedora
Component: pyserial
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paul P Komkoff Jr
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-23 06:47 UTC by nvwarr
Modified: 2019-12-27 19:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-27 19:05:43 UTC


Attachments (Terms of Use)

Description nvwarr 2019-07-23 06:47:38 UTC
Description of problem:

The symbolic links /usr/bin/miniterm-3.7.py and /usr/bin/miniterm-2.7.py point to non-existent files

Version-Release number of selected component (if applicable):

python3-pyserial-3.4-2.fc30.noarch
python2-pyserial-3.4-2.fc30.noarch

How reproducible:
Always

Steps to Reproduce:
1. install python3-pyserial and/or python2-pyserial
2. the symlinks are incorrect

Actual results:

 /usr/bin/miniterm-3.7.py -> /usr/bin/miniterm.py-3
 /usr/bin/miniterm-2.7.py -> /usr/bin/miniterm.py-2

Expected results:

 /usr/bin/miniterm-3.7.py -> miniterm-3.py
 /usr/bin/miniterm-2.7.py -> miniterm-2.py

Additional info:

It can be fixed by changing the two ln lines in the .spec file to:

ln -sf miniterm-3.py %{buildroot}/%{_bindir}/miniterm-%{python3_version}.py
ln -sf miniterm-2.py %{buildroot}/%{_bindir}/miniterm-%{python2_version}.py

(which also gets rid of the warning about absolute symlinks).

Comment 1 Ben Cotton 2019-08-13 16:56:38 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 2 Ben Cotton 2019-08-13 18:57:48 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 3 "FeRD" (Frank Dana) 2019-12-27 19:05:43 UTC

*** This bug has been marked as a duplicate of bug 1421373 ***


Note You need to log in before you can comment on or make changes to this bug.