Bug 173235 - kmail writes debug info to ~/.xsession-errors
kmail writes debug info to ~/.xsession-errors
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
4
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-15 09:43 EST by Vlado Potisk
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-03 10:11:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vlado Potisk 2005-11-15 09:43:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
kmail writes to ~/.xsession-errors file something that looks like debug info. Over 20 lines are added on every mail check that runs every minute. Here is a sample:


kmail: processNextCheck, remaining 0
kmail: account Internet mail finished check
kmail: connections to server xx.xx.sk now 0
kmail: processNextCheck, remaining 1
kmail: for host  current connections=0 and limit is 0
kmail: connection limit reached: false
kmail: processing next mail check for local mail
kmail: processNextCheck, remaining 0
kmail: account local mail finished check
kmail: processNextCheck, remaining 1
kmail: for host xx.xx.sk current connections=0 and limit is 0
kmail: connection limit reached: false
kmail: processing next mail check for Internet mail
kmail: check mail started - connections for host xx.xx.sk now is 1
kmail: Data: <End>
kmail: [void KMAcctExpPop::slotJobFinished()] stage == List
kmail: Data: <End>
kmail: [void KMAcctExpPop::slotJobFinished()] stage == Uidl
kmail: Data: <End>
kmail: [void KMAcctExpPop::processRemainingQueuedMessages()]
kmail: [void KMAcctExpPop::slotJobFinished()] stage == Quit
kmail: [void KMAcctExpPop::saveUidList()]


Version-Release number of selected component (if applicable):
kdepim-3.4.2-0.fc4.3

How reproducible:
Always

Steps to Reproduce:
1. use kmail, leave it poll the mailbox for new mail


Actual Results:  thousands of lines written to ~/.xsession-errors after a while

Expected Results:  only error messages should go to this file

Additional info:
Comment 1 Vlado Potisk 2005-11-16 11:00:50 EST
Proposed patch:

in the file /usr/share/config/kdebugrc look for the kmail section:
  # KMail
  [5006]
  InfoOutput=2
and change the value from 2 to 4. (Value 4 means "off")
Comment 2 Ngo Than 2006-05-03 10:11:32 EDT
it's now fixed in our CVS. The next kde-update will include this fix. Thanks for
your report.

Note You need to log in before you can comment on or make changes to this bug.