Bug 1732387 - timeout expired waiting for volumes to attach or mount for pod
Summary: timeout expired waiting for volumes to attach or mount for pod
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.11.z
Assignee: Joel Smith
QA Contact: Sunil Choudhary
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-23 09:26 UTC by Fatima
Modified: 2019-11-11 09:19 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-11 09:19:00 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Fatima 2019-07-23 09:26:02 UTC
Description of problem:

Deployments sometimes fail with the event:
timeout expired waiting for volumes to attach or mount for pod "namespace"/"application-name-2-deploy". list of unmounted volumes=[deployer-token-xxxxx]. list of unattached volumes=[deployer-token-xxxxx]

Version-Release number of selected component (if applicable):

OCP 3.11.98




This issue is quite similar to this bug --> https://bugzilla.redhat.com/show_bug.cgi?id=1583673

but the workaround provided for the above bug doesn't work in this case:

https://access.redhat.com/solutions/3932711


Additional info:

I will add the sos-report with debug level logs for better clarity.


Note You need to log in before you can comment on or make changes to this bug.