Bug 1732405 - Few missing obsolete package for f30+
Summary: Few missing obsolete package for f30+
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-obsolete-packages
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jason Tibbitts
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-23 10:08 UTC by Nicolas Chauvet (kwizart)
Modified: 2019-07-24 06:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-23 16:39:11 UTC


Attachments (Terms of Use)

Description Nicolas Chauvet (kwizart) 2019-07-23 10:08:32 UTC
Description of problem:
Here is a list of remaining package not in repos after updating (dnf update --releasever=30)

Version-Release number of selected component (if applicable):

# dnf list extras --quiet
Additional packages:
beignet.x86_64            1.3.2-5.fc29    @fedora                      
clutter-gst2.x86_64       2.0.18-5.fc28   @fedora                      
cockpit-integration-tests.x86_64    151-2.fc26      @updates                     
cockpit-kubernetes.x86_64 194-2.fc29      @updates                     
compat-libicu60.x86_64    60.2-2.fc29     @fedora                      
ghostscript-fonts.noarch  5.50-36.fc26    @@commandline                
hesiod.x86_64             3.2.1-14.fc29   @updates-testing             
ladspa-swh-plugins.x86_64 0.4.17-2.fc29   @fedora                      
libgltf.x86_64            0.1.0-10.fc29   @fedora                      
mozjs24.x86_64            24.2.0-11.fc26  @@commandline                
net6.x86_64               1.3.14-17.fc29  @fedora                      
obby.x86_64               0.4.8-17.fc29   @fedora                      
pam_pkcs11.x86_64         0.6.8-8.fc24    @anaconda                    
python2-custodia.noarch   0.6.0-4.fc29    @fedora                      
python2-sssdconfig.noarch 2.1.0-2.fc29    @updates                     
python2-yubico.noarch     1.3.2-10.fc29   @fedora                      
sobby.x86_64              0.4.7-18.fc29   @fedora                      
tabish-eeyek-fonts.noarch

How reproducible:
dnf update --releasever (initial install from f24 or older).

Actual results:
they remains on the system despite been removed from repos

Expected results:
They should be all obsoleted

Additional info:
should we expect them to be handled by the fedora-obsolete package or by the package or origin (cockpit for the related sub-packages ?).

Comment 1 Miro Hrončok 2019-07-23 10:56:29 UTC
Is any of the package blocking a clean upgrade to F30? The purpose of fedora-obsolete-packages is not to remove all removed packages, but to unblock broken upgrades be removing packages that cause trouble.

Comment 2 Nicolas Chauvet (kwizart) 2019-07-23 16:39:11 UTC
Well, I think theses will block at some point...
But since I guess I've removed the one really blocking my transition, it doesn't worth to take theses into account.

Closing. thx for the answer.

Comment 3 Nicolas Chauvet (kwizart) 2019-07-24 06:00:45 UTC
Okay, I've founded the one blocking:
it's python2-rpkg (that is not available on f30 without been obsoleted obviously).
I will forward to the rpkg component.


Note You need to log in before you can comment on or make changes to this bug.