Bug 173248 - kword steals .doc file association
kword steals .doc file association
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: koffice (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-15 11:56 EST by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-07 15:09:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-11-15 11:56:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Epiphany/1.6.5

Description of problem:
I installed kword to convert and old document, and now all .doc documents open in kword, and not openoffice. ugh.

Probably some good reason for this, but given that the standard office suite in FC4 is openoffice, koffice should come second.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Need Real Name 2005-11-24 13:07:40 EST
It's stolen .odt too. Can it be changed back in a gui, or should I file a bug?
Comment 2 Andreas Bierfert 2006-01-16 17:54:18 EST
I will look into it...
Comment 3 Andreas Bierfert 2006-01-19 06:53:38 EST
Hm ok, finally got the time. 

Here is where I see the problem:
Dropping the mime typ stuff from the desktop entries would not be a big problem.
The reason I hesitate to do so is this:
If I remove this it would mean for users that don't install ooo that those files
are not owned by any application. Putting triggers into the scripts is a
solution which I do not like at all. Isn't there a clean(er) solution to this?
Comment 4 Need Real Name 2006-01-19 12:44:23 EST
So if two things have the same mime type, I can't set a preference?
Comment 5 Andreas Bierfert 2006-01-19 16:29:34 EST
Thats what I would like to have... like a system-control-center where those mime
things are inserted and then you have a list like

odt: ooo, kword, ...

and the user can choose the default. If the list is empty the first one
installed will get the default...

I don't know if this is possible or not will have to investigate this further...
Comment 6 Rex Dieter 2006-02-07 09:05:32 EST
Users certainly can choose a preference (at least in KDE they can, can't comment
on Gnome).

See /usr/share/config/profilerc as an example how an admin can set a system-wide
default preferences (ie, you can prioritize preference).
Comment 7 Need Real Name 2006-02-07 12:02:11 EST
Thanks.

There seems to be no per-user gui way of changing or removing an association.
It's worsened by kword stealing a document type away from OO.org.
Comment 8 Rex Dieter 2006-02-07 12:09:21 EST
> There seems to be no per-user gui way of changing or removing an association.

Yes there is.  
KDE Control Center->KDE Components->File Associations.
Find the mimetype to modify, Change "Application Preference Order" to suit.

>  It's worsened by kword stealing a document type away from OO.org.

It's not "stealing" anything.  They both offer to be able to handle .odt
doc-types, that's all.  I think the default ends up being whoever comes first
alphabetically, unfortunately.
Comment 9 Need Real Name 2006-02-07 12:20:58 EST
(In reply to comment #8)
> > There seems to be no per-user gui way of changing or removing an association.
> 
> Yes there is.  
> KDE Control Center->KDE Components->File Associations.
> Find the mimetype to modify, Change "Application Preference Order" to suit.

But there isn't in Gnome, which is the default (isn't KDE extras?).

> >  It's worsened by kword stealing a document type away from OO.org.
> 
> It's not "stealing" anything.  They both offer to be able to handle .odt
> doc-types, that's all.  I think the default ends up being whoever comes first
> alphabetically, unfortunately.

It is stealing if I don't want it changed, and I can't change it back!
Comment 10 Rex Dieter 2006-02-07 12:25:23 EST
Re: Gnome's (in)ability to change mime-type/file-association defaults

That's not koffice's fault.  Bugzilla against gnome then.

FYI, abiword (which also can handle .doc files) probably will do the same thing
("stealing" .doc).

p.s. KDE isn't in Extras (yet).
Comment 11 Andreas Bierfert 2006-02-07 15:09:51 EST
Thanks for making this clear Rex... I did not know the KDE way of changing this
but it certainly seems like there is a black hole in Gnome for this. I will
close this bug. However I agree that there should be an option for Gnome to
choose a default mime type. Please go ahead and file a bug against gnome.
Comment 12 Need Real Name 2006-02-07 17:10:54 EST
I agree that the bug is misfiled, and with your statement about a "black hole in
Gnome", but I don't see why opening a new bug will help.

If the bug is miscategorised, then update the title and change the category.

Entering a new bug takes time, and asking someone else to do it takes even longer.
Comment 13 Rex Dieter 2006-02-07 21:40:06 EST
Bugzilla Reporters can reopen/reassign (their) bugs.  Knock yourself out.
Comment 14 Andreas Bierfert 2006-02-08 01:18:39 EST
As Rex said -> you can always reopen and or reassign it if and how you feel fit.
The problem here is: I as koffice maintainer can not really do anything about
this from a koffice point of view and I doubt that reassigning this bug to gnome
would do you any good. After all what we are looking for is a feature
enhancement in gnome and that should be placed in the upstream bugzilla
(http://bugzilla.gnome.org/).

If you don't have the time I certainly can do this for you. Let me know.

Note You need to log in before you can comment on or make changes to this bug.