Bug 173253 - New Storage engine not build in
New Storage engine not build in
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
David Lawrence
http://dev.mysql.com/doc/refman/5.1/e...
: FutureFeature, Reopened
: 388731 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-15 13:02 EST by Remi COLLET
Modified: 2013-07-02 23:07 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 09:41:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Remi COLLET 2005-11-15 13:02:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.12) Gecko/20050927 Fedora/1.0.7-1.1.fc3.remi Firefox/1.0.7

Description of problem:
Happy to see MySQL 5.0.x in rawhide.

But the new storage engines are not build in.

Options need to build them during configure are :
--with-archive-storage-engine : Enable the Archive Storage Engine
--with-csv-storage-engine : Enable the CSV Storage Engine
--with-blackhole-storage-engine : Enable the Blackhole Storage Engine
--with-federated-storage-engine : Enable the MySQL Federated Storage Engin

I think it's could be (very) useful to add them.

Cordialy

Version-Release number of selected component (if applicable):
mysql-5.0.15-2

How reproducible:
Always

Steps to Reproduce:
-
  

Actual Results:  -

Expected Results:  -

Additional info:

-
Comment 1 Tom Lane 2005-11-15 22:56:01 EST
What are these actually useful for ... and if they are so useful, why didn't MySQL AB choose to build them 
by default?

I'm not really inclined to bloat our distribution by compiling stuff that the upstream developers don't think 
is needed.
Comment 2 Remi COLLET 2005-11-26 14:46:51 EST
MySQL AB distribute 2 versions of the server.

1. MySQL-server (standard) which only include the archive storage engine
2. MySQL-Max which include all the storage engines (archive, csv, backhole et
federated)

I think this new features worth to be tested by the usere.
How can they test it, if they are not included in the distro ?
Comment 3 Colin Charles 2005-12-12 04:49:57 EST
We (Fedora) only provides MySQL-server, which is the standard release. The
MySQL-Max release is labelled experimental, and has all the storage engines like
csv/federated/blackhole. For more information about the engines, read
http://dev.mysql.com/doc/refman/5.0/en/storage-engines.html

So, should we enable all these by default in our mysql-server? I doubt it. This
may make for an excellent Extras package however.
Comment 4 Gabriel Somlo 2007-12-10 17:05:47 EST
*** Bug 388731 has been marked as a duplicate of this bug. ***
Comment 5 John Poelstra 2008-07-09 01:02:24 EDT
Given comment #3 and the fact that extras is no more should this RFE remain open?
Comment 6 Tom Lane 2008-07-09 01:20:59 EDT
I'm still of the opinion that these extra storage engines are not useful enough to be part of the core 
Fedora distribution.  The tiny number of requests for 'em seems adequate evidence for that position.

Upstream is working on a "pluggable" storage engine architecture, which I believe will make it feasible to 
distribute add-on storage engines as separately-built SRPMs.  My inclination is to hold on till that 
materializes, and then encourage whoever is sufficiently interested to maintain such a separate SRPM.
Comment 7 Gabriel Somlo 2008-07-09 07:46:43 EDT
Re: comment #6: They're not built in because nobody uses them. Nobody uses them
because they're not built in. Chicken, meet egg... :)

I stand by my original position that it makes sense not to build the extra
engines in a conservative distribution such as RHEL. However, Fedora being
positioned as a "cutting edge" distro, meant to enable its users to try the
latest and greatest, it would make sense to include them there.
Comment 8 Remi Collet 2008-08-09 05:47:48 EDT
Hi,

I've made some tests on pluggable storage engine.

I think it will be really simpler to have a simple SRPM with optional storage engine as sub-packages (than a separate SRPM using the same source / patches)

But, the main issue I think is that this options must be enabled by a SQL command (INSTALL PLUGIN ...), which doesn't seem possible in %post, %postun scriptlet.


Regards
Comment 9 Joe Julian 2008-12-04 17:42:33 EST
Apparently the upstream provider agrees with Tom that they should have been built by default.

From the mysql bugtracker:
Bug #28844  	CSV Engine not available in Enterprise Builds

[9 Jun 2007 19:46] Paul DuBois

Noted in 5.0.44 changelog.

Enterprise builds did not include the CSV storage engine. CSV is now
included in Enterprise builds for all platforms except Windows, QNX,
and NetWare.
Comment 11 Tom Lane 2009-02-13 21:47:02 EST
mysql 5.1 appears to build all of these by default (some are statically linked and others are plugins).
So this is done, at least as far as rawhide is concerned.
Comment 12 David Ash 2009-02-16 03:59:30 EST
Hi apologies for opening this.  Please feel free to close if I am mistaken.

It seems to me like rawhide still does not have this compiled in as per upstream.  Did you mean that this was in rawhide with the compile option "--with-archive-storage-engine"? or is it included some other way?

Rawhide version i tested with:

[root@fedora ~]# rpm -q mysql-server
mysql-server-5.1.31-1.fc11.x86_64

mysql> show engines;
+------------+---------+------------------------------------------------------------+--------------+------+------------+
| Engine     | Support | Comment                                                    | Transactions | XA   | Savepoints |
+------------+---------+------------------------------------------------------------+--------------+------+------------+
| ndbcluster | NO      | Clustered, fault-tolerant tables                           | NULL         | NULL | NULL       | 
| MRG_MYISAM | YES     | Collection of identical MyISAM tables                      | NO           | NO   | NO         | 
| CSV        | YES     | CSV storage engine                                         | NO           | NO   | NO         | 
| MyISAM     | DEFAULT | Default engine as of MySQL 3.23 with great performance     | NO           | NO   | NO         | 
| InnoDB     | YES     | Supports transactions, row-level locking, and foreign keys | YES          | YES  | YES        | 
| MEMORY     | YES     | Hash based, stored in memory, useful for temporary tables  | NO           | NO   | NO         | 
+------------+---------+------------------------------------------------------------+--------------+------+------------+
6 rows in set (0.00 sec)
Comment 13 Tom Lane 2009-02-16 09:41:07 EST
It's a plugin --- you need to do "INSTALL PLUGIN" or whatever the command is.
Comment 14 David Ash 2009-02-16 20:03:36 EST
Ah ok yes thanks that seems to work ok:

mysql> install plugin archive soname 'ha_archive.so';
Query OK, 0 rows affected (0.10 sec)

"show engines;" and "create table test engine archive;" seems to produce the required ARZ database

Note You need to log in before you can comment on or make changes to this bug.