Bug 1732584 - cryptography>=1.9 is required
Summary: cryptography>=1.9 is required
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: certbot
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: James Hogarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-23 19:30 UTC by Vadim Raskhozhev
Modified: 2019-07-23 20:35 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-23 20:35:27 UTC


Attachments (Terms of Use)

Description Vadim Raskhozhev 2019-07-23 19:30:41 UTC
certbot-0.36.0-1.el7 crashes on execution:
Traceback (most recent call last):
  File "/usr/bin/certbot", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 3011, in <module>
    parse_requirements(__requires__), Environment()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 630, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
pkg_resources.VersionConflict: (cryptography 1.7.2 (/usr/lib64/python2.7/site-packages), Requirement.parse('cryptography>=1.9'))

Steps to Reproduce:
1. yum update certbot # on CentOS 7 with EPEL enabled, of course
2. certbot

Actual results: a crash

Expected results: normal work

Comment 1 Vadim Raskhozhev 2019-07-23 19:32:54 UTC
Forgot to mention: downgrade to certbot-0.35.1-1.el7 changes nothing.

Comment 2 Vadim Raskhozhev 2019-07-23 20:35:27 UTC
Sorry for the noize, this is completely my bad: I've got too fresh pyOpenSSL installed from an internal repo for some mysterious reason. After downgrading pyOpenSSL to what's available from regular CentOS repos certbot is working as expected. Closing this NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.