Bug 173288 - ATAPI DVD recorder problem with benq dw1640
ATAPI DVD recorder problem with benq dw1640
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-15 18:10 EST by Thomas Groß
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-21 11:13:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Groß 2005-11-15 18:10:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
I have a Problem with my benq dw1640 DVD recorder with kernel kernel-2.6.13-1.1532_FC4.

It works correctly with kernel-2.6.12-1.1447_FC4.

If i boot with the 2.6.13 kernel i get the following in the boot log:
kernel: hdc: Maxtor 6Y120L0, ATA DISK drive
kernel: hdd: BENQ DVD DD DW1640, ATAPI CD/DVD-ROM drive
kernel: ide1 at 0x170-0x177,0x376 on irq 15
.
. lines erased
.
kernel: hdd: status timeout: status=0xd0 { Busy }
kernel: ide: failed opcode was: unknown
kernel: hdd: DMA disabled
kernel: hdd: ATAPI reset complete
kernel: hdd: ATAPI 48X DVD-ROM DVD-R CD-R/RW drive, 2048kB Cache

After that DMA is disabled for hdd. I can read parts of a cdrom inserted into the recorder. But i get errors when reading files.

This is from the /var/log/messages:

kernel: hdd: cdrom_read_intr: Bad transfer size 65534
kernel:   This drive is not supported by this version of the driver
kernel: end_request: I/O error, dev hdd, sector 892480
kernel: Buffer I/O error on device hdd, logical block 223120
kernel: hdd: status error: status=0x58 { DriveReady SeekComplete DataRequest }
kernel: ide: failed opcode was: unknown
kernel: hdd: drive not ready for command
kernel: hdd: status error: status=0x58 { DriveReady SeekComplete DataRequest }
kernel: ide: failed opcode was: unknown
kernel: hdd: drive not ready for command
kernel: hdd: status error: status=0x58 { DriveReady SeekComplete DataRequest }
kernel: ide: failed opcode was: unknown
kernel: hdd: drive not ready for command
kernel: hdd: status error: status=0x58 { DriveReady SeekComplete DataRequest }
kernel: ide: failed opcode was: unknown
kernel: hdd: drive not ready for command
kernel: hdd: ATAPI reset complete

I cannot reproduce this error with kernel-2.6.12-1.1447_FC4.

   thomas


Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1532_FC4

How reproducible:
Always

Steps to Reproduce:
1. Boot System
2. Insert CD
3. Read files from CD
  

Actual Results:  Errors while reading files from CD.

Expected Results:  CD should be readable.

Additional info:

Nov  7 19:51:52 oggelpop kernel: Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
Nov  7 19:51:52 oggelpop kernel: ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
Nov  7 19:51:52 oggelpop kernel: VP_IDE: IDE controller at PCI slot 0000:00:04.1
Nov  7 19:51:52 oggelpop kernel: VP_IDE: chipset revision 6
Nov  7 19:51:52 oggelpop kernel: VP_IDE: not 100% native mode: will probe irqs later
Nov  7 19:51:52 oggelpop kernel: VP_IDE: VIA vt82c686b (rev 40) IDE UDMA100 controller on pci0000:00:04.1
Nov  7 19:51:52 oggelpop kernel:     ide0: BM-DMA at 0xd800-0xd807, BIOS settings: hda:DMA, hdb:DMA
Nov  7 19:51:52 oggelpop kernel:     ide1: BM-DMA at 0xd808-0xd80f, BIOS settings: hdc:DMA, hdd:DMA
Nov  7 19:51:52 oggelpop kernel: hda: IBM-DJNA-352030, ATA DISK drive
Nov  7 19:51:52 oggelpop kernel: hdb: Maxtor 6Y120L0, ATA DISK drive
Nov  7 19:51:52 oggelpop kernel: ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Nov  7 19:51:52 oggelpop kernel: hdc: Maxtor 6Y120L0, ATA DISK drive
Nov  7 19:51:52 oggelpop kernel: hdd: BENQ DVD DD DW1640, ATAPI CD/DVD-ROM drive
Nov  7 19:51:52 oggelpop kernel: ide1 at 0x170-0x177,0x376 on irq 15
Nov  7 19:51:52 oggelpop kernel: hda: max request size: 128KiB
Nov  7 19:51:52 oggelpop kernel: hda: 39876480 sectors (20416 MB) w/1966KiB Cache, CHS=39560/16/63, UDMA(33)
Nov  7 19:51:52 oggelpop kernel: hda: cache flushes not supported
Nov  7 19:51:52 oggelpop kernel:  hda: hda1 hda2 < hda5 hda6 >
Nov  7 19:51:52 oggelpop kernel: hdb: max request size: 128KiB
Nov  7 19:51:52 oggelpop kernel: hdb: 240121728 sectors (122942 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(100)
Nov  7 19:51:52 oggelpop kernel: hdb: cache flushes supported
Nov  7 19:51:52 oggelpop kernel:  hdb: hdb1 hdb2 hdb3
Nov  7 19:51:52 oggelpop kernel: hdc: max request size: 128KiB
Nov  7 19:51:52 oggelpop kernel: hdc: 240121728 sectors (122942 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(100)
Nov  7 19:51:52 oggelpop kernel: hdc: cache flushes supported
Nov  7 19:51:52 oggelpop kernel:  hdc: hdc1 hdc2 hdc3 hdc4 < hdc5 hdc6 hdc7 >
Nov  7 19:51:52 oggelpop kernel: hdd: status timeout: status=0xd0 { Busy }
Nov  7 19:51:52 oggelpop kernel: ide: failed opcode was: unknown
Nov  7 19:51:52 oggelpop kernel: hdd: DMA disabled
Nov  7 19:51:52 oggelpop kernel: hdd: ATAPI reset complete
Nov  7 19:51:52 oggelpop kernel: hdd: ATAPI 126X DVD-ROM DVD-R CD-R/RW drive, 2048kB Cache
Nov  7 19:51:52 oggelpop kernel: Uniform CD-ROM driver Revision: 3.20
Comment 1 Thomas Groß 2005-11-16 15:22:05 EST
I can no longer reproduce this Bug with kernel-2.6.14-1.1637_FC4 consider it fixed.

Note You need to log in before you can comment on or make changes to this bug.