Bug 1733072 - [OVN]"Unit ovn-northd.service could not be found" report when install OVN central and host package
Summary: [OVN]"Unit ovn-northd.service could not be found" report when install OVN cen...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux Fast Datapath
Classification: Red Hat
Component: OVN
Version: FDP 19.E
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Mark Michelson
QA Contact: Jianlin Shi
URL:
Whiteboard:
: 1771907 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-25 07:23 UTC by haidong li
Modified: 2020-08-21 14:58 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-21 14:58:46 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description haidong li 2019-07-25 07:23:49 UTC
Description of problem:
"Unit ovn-northd.service could not be found" report when install OVN central and host packages

Version-Release number of selected component (if applicable):
[root@dell-per730-42 ~]# uname -a
Linux dell-per730-42.rhts.eng.pek2.redhat.com 4.18.0-107.el8.x86_64 #1 SMP Fri Jun 14 13:46:34 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
[root@dell-per730-42 ~]# rpm -qa | grep openvswitch
openvswitch2.11-2.11.0-18.el8fdp.x86_64
openvswitch-selinux-extra-policy-1.0-16.el8fdp.noarch
[root@dell-per730-42 ~]# rpm -qa | grep ovn
ovn2.11-2.11.0-26.el8fdp.x86_64
ovn2.11-central-2.11.0-26.el8fdp.x86_64
ovn2.11-host-2.11.0-26.el8fdp.x86_64
[root@dell-per730-42 ~]# 

How reproducible:
everytime

Steps to Reproduce:
[root@dell-per730-17 ~]# rpm -ivh http://download-node-02.eng.bos.redhat.com/brewroot/packages/openvswitch2.11/2.11.0/18.el8fdp/x86_64/openvswitch2.11-2.11.0-18.el8fdp.x86_64.rpm 
Retrieving http://download-node-02.eng.bos.redhat.com/brewroot/packages/openvswitch2.11/2.11.0/18.el8fdp/x86_64/openvswitch2.11-2.11.0-18.el8fdp.x86_64.rpm
Verifying...                          ################################# [100%]
Preparing...                          ################################# [100%]
Updating / installing...
   1:openvswitch2.11-2.11.0-18.el8fdp ################################# [100%]
[root@dell-per730-17 ~]# rpm -ivh http://download-node-02.eng.bos.redhat.com/brewroot/packages/ovn2.11/2.11.0/26.el8fdp/x86_64/ovn2.11-2.11.0-26.el8fdp.x86_64.rpm
Retrieving http://download-node-02.eng.bos.redhat.com/brewroot/packages/ovn2.11/2.11.0/26.el8fdp/x86_64/ovn2.11-2.11.0-26.el8fdp.x86_64.rpm
Verifying...                          ################################# [100%]
Preparing...                          ################################# [100%]
Updating / installing...
   1:ovn2.11-2.11.0-26.el8fdp         ################################# [100%]
[root@dell-per730-17 ~]# rpm -ivh http://download-node-02.eng.bos.redhat.com/brewroot/packages/ovn2.11/2.11.0/26.el8fdp/x86_64/ovn2.11-central-2.11.0-26.el8fdp.x86_64.rpm
Retrieving http://download-node-02.eng.bos.redhat.com/brewroot/packages/ovn2.11/2.11.0/26.el8fdp/x86_64/ovn2.11-central-2.11.0-26.el8fdp.x86_64.rpm
Verifying...                          ################################# [100%]
Preparing...                          ################################# [100%]
Unit ovn-northd.service could not be found.
Updating / installing...
   1:ovn2.11-central-2.11.0-26.el8fdp ################################# [100%]
[root@dell-per730-17 ~]# rpm -ivh http://download-node-02.eng.bos.redhat.com/brewroot/packages/ovn2.11/2.11.0/26.el8fdp/x86_64/ovn2.11-host-2.11.0-26.el8fdp.x86_64.rpm
Retrieving http://download-node-02.eng.bos.redhat.com/brewroot/packages/ovn2.11/2.11.0/26.el8fdp/x86_64/ovn2.11-host-2.11.0-26.el8fdp.x86_64.rpm
Verifying...                          ################################# [100%]
Preparing...                          ################################# [100%]
Unit ovn-controller.service could not be found.
Updating / installing...
   1:ovn2.11-host-2.11.0-26.el8fdp    ################################# [100%]

Actual results:


Expected results:
no extra info displayed

Additional info:

Comment 1 Mark Michelson 2019-08-02 20:19:47 UTC
This message is being displayed due to a preinstallation hook in the spec file. When ovn-host is installed, it tries to determine if ovn-controller is running, and if the old openvswitch-ovn-host package is installed. If the service is running, then the installation of ovn-host will automatically start the service again as part of installation. The same check is performed for the ovn-central package, except that it checks if ovn-northd is running and if the old openvswitch-ovn-central package is installed.

Since you are installing the packages on a new system, when systemd checks if ovn-controller or ovn-northd is running, it returns an error saying the service cannot be found. This doesn't actually cause a problem, but it can be alarming to see such a message during package installation. I think the proper fix in this case is to suppress the output from the `systemctl status` command.

Comment 2 Mark Michelson 2019-08-06 19:04:00 UTC
I've submitted a fix upstream and have fixed this problem in the fast-datapth-next-rhel-7 branch.

Comment 3 Mark Michelson 2020-04-13 13:57:18 UTC
*** Bug 1771907 has been marked as a duplicate of this bug. ***

Comment 4 Numan Siddique 2020-08-21 14:58:46 UTC
The BZ 1771907 which is a duplicate of this BZ has addressed it and 1771907 is already closed.
So closing this BZ.


Note You need to log in before you can comment on or make changes to this bug.