Bug 1733191 - Host group creation does not validate os and architecture
Summary: Host group creation does not validate os and architecture
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Host Group
Version: 6.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Tasos Papaioannou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-25 11:19 UTC by Peter Dragun
Modified: 2021-01-19 21:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-19 21:34:24 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Peter Dragun 2019-07-25 11:19:12 UTC
Description of problem:
When creating or updating hostgoup in cli or api despite not linked architecture and operating system, host group is successfully created.

Version-Release number of selected component (if applicable):


How reproducible:
allways

Steps to Reproduce:
1. Create two architectures.
# hammer architecture create --name arch1
# hammer architecture create --name arch2
2. Create os based on architecture 1
# hammer os create --name test_os --architectures arch1 --major 1
3. Create host group with architecture 2 and os
# hammer hostgroup create --name test --architecture arch2 --operatingsystem 'test_os 1'

Actual results:
Hostgroup is crated.

# hammer hostgroup info --name test
Id:                    254
Name:                  test
Title:                 test
Network:               

Operating system:      
    Architecture:     arch2
    Operating System: test_os 1
...

# hammer os info --title 'test_os 1'
Id:                 46
Title:              test_os 1
Release name:       
Family:             
Name:               test_os
Major version:      1
...


Expected results:
Error message, architecture in os is different that architecture in hostgroup

Additional info:

Comment 5 Mike McCune 2020-12-09 22:17:57 UTC
Upon review of our valid but aging backlog the Satellite Team has concluded that this Bugzilla does not meet the criteria for a resolution in the near term, and are planning to close in approximately a month. If you have any concerns about this, please contact your Red Hat Account team.  Thank you.

Comment 6 Mike McCune 2021-01-19 21:27:15 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact your Red Hat Account Team. Thank you.


Note You need to log in before you can comment on or make changes to this bug.