Bug 1733224 - ovs bonding options not taken into account
Summary: ovs bonding options not taken into account
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: James Slagle
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-25 13:13 UTC by Miguel Angel Nieto
Modified: 2019-07-26 10:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-26 10:52:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Miguel Angel Nieto 2019-07-25 13:13:52 UTC
Description of problem:

Some bonding options in the templates are discarded. According to the following document, it should be able to configure options :other-config:lacp-fallback-ab and other_config:lacp-time, but they are discarded.
https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/13/html/advanced_overcloud_customization/overcloud-network-interface-bonding

Using the following template:
https://gitlab.cee.redhat.com/mnietoji/deployment_templates/tree/master/balance-tcp/ospd-13-vxlan-dpdk-sriov-ctlplane-dataplane-bonding-hybrid_panther08_balance-tcp_lacp_nic_partitioning

generates the following /etc/os-net-config/config.json, where those options are missing

{"network_config": [{"defroute": false, "name": "nic1", "type": "interface", "use_dhcp": false}, {"addresses": [{"ip_netmask": "192.0.110.6/24"}], "dns_servers": ["10.46.0.31", "10.46.0.32"], "name": "nic2", "routes": [{"ip_netmask": "169.254.169.254/32", "next_hop": "192.0.110.1"}, {"default": true, "next_hop": "192.0.110.1"}], "type": "interface", "use_dhcp": false}, {"defroute": false, "name": "nic3", "type": "interface", "use_dhcp": false}, {"defroute": false, "name": "nic4", "type": "interface", "use_dhcp": false}, {"defroute": false, "hotplug": true, "mtu": 9000, "name": "nic7", "nm_controlled": true, "numvfs": 14, "promisc": false, "type": "sriov_pf", "use_dhcp": false}, {"defroute": false, "hotplug": true, "mtu": 9000, "name": "nic8", "nm_controlled": true, "numvfs": 14, "promisc": false, "type": "sriov_pf", "use_dhcp": false}, {"bonding_options": "mode=active-backup", "members": [{"device": "nic7", "type": "sriov_vf", "vfid": 1}, {"device": "nic8", "type": "sriov_vf", "vfid": 1}], "name": "internal_bond", "type": "linux_bond", "use_dhcp": false}, {"bonding_options": "mode=active-backup", "members": [{"device": "nic7", "type": "sriov_vf", "vfid": 2}, {"device": "nic8", "type": "sriov_vf", "vfid": 2}], "name": "storage_bond", "type": "linux_bond", "use_dhcp": false}, {"addresses": [{"ip_netmask": "10.10.112.109/24"}], "device": "internal_bond", "type": "vlan", "vlan_id": 512}, {"addresses": [{"ip_netmask": "10.10.114.100/24"}], "device": "storage_bond", "type": "vlan", "vlan_id": 514}, {"addresses": [{"ip_netmask": "10.10.113.100/24"}], "members": [{"members": [{"members": [{"device": "nic8", "type": "sriov_vf", "vfid": 3}], "name": "dpdk0", "type": "ovs_dpdk_port"}, {"members": [{"device": "nic7", "type": "sriov_vf", "vfid": 3}], "name": "dpdk1", "type": "ovs_dpdk_port"}], "mtu": 9000, "name": "dpdkbond0", "rx_queue": 2, "type": "ovs_dpdk_bond"}], "name": "br-link0", "ovs_extra": ["set port br-link0 tag=513"], "type": "ovs_user_bridge", "use_dhcp": false}, {"defroute": false, "hotplug": true, "mtu": 9000, "name": "nic9", "nm_controlled": true, "numvfs": 14, "promisc": false, "type": "sriov_pf", "use_dhcp": false}, {"defroute": false, "hotplug": true, "mtu": 9000, "name": "nic10", "nm_controlled": true, "numvfs": 14, "promisc": false, "type": "sriov_pf", "use_dhcp": false}, {"members": [{"members": [{"members": [{"device": "nic9", "type": "sriov_vf", "vfid": 1}], "name": "dpdk2", "type": "ovs_dpdk_port"}, {"members": [{"device": "nic10", "type": "sriov_vf", "vfid": 1}], "name": "dpdk3", "type": "ovs_dpdk_port"}], "mtu": 9000, "name": "dpdkbond1", "ovs_options": "bond_mode=balance-tcp lacp=active", "rx_queue": 2, "type": "ovs_dpdk_bond"}], "name": "br-performance", "type": "ovs_user_bridge", "use_dhcp": false}]}


Version-Release number of selected component (if applicable):


How reproducible:
Install the following templates
https://gitlab.cee.redhat.com/mnietoji/deployment_templates/tree/master/balance-tcp/ospd-13-vxlan-dpdk-sriov-ctlplane-dataplane-bonding-hybrid_panther08_balance-tcp_lacp_nic_partitioning

Check in the compute in etc/os-net-config/config.json file if all the bonding options have been parsed



Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Miguel Angel Nieto 2019-07-26 10:52:06 UTC
the problem is with updates, with a new deployment it works. So I am going to close this bz and open a new one


Note You need to log in before you can comment on or make changes to this bug.