Bug 1733238 - Google talk account fails to connect - ssl handshake failed
Summary: Google talk account fails to connect - ssl handshake failed
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pidgin
Version: 7.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Debarshi Ray
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-25 13:48 UTC by Petr Schindler
Modified: 2020-02-12 13:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-12 13:57:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
Output of pidgin -d (17.12 KB, text/plain)
2019-07-25 13:48 UTC, Petr Schindler
no flags Details

Description Petr Schindler 2019-07-25 13:48:02 UTC
Created attachment 1593416 [details]
Output of pidgin -d

Description of problem:
Logging in to google talk account fails because of handshake failed. When I try to log in on rhel 8.1 (pidgin-2.13.0-5.el8) it works properly.

I run pidgin with -d and the conversation and the communication with server looks like this:

(09:39:53) jabber: Sending (pidgintest.2@gmail.com): <?xml version='1.0' ?>
(09:39:53) jabber: Sending (pidgintest.2@gmail.com): <stream:stream to='gmail.com' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0'>
(09:39:53) jabber: Recv (138): <stream:stream from="gmail.com" id="34811A54270E58B7" version="1.0" xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client">
(09:39:53) jabber: Recv (241): <stream:features><starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls"><required/></starttls><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>X-OAUTH2</mechanism><mechanism>X-GOOGLE-TOKEN</mechanism></mechanisms></stream:features>
(09:39:53) jabber: Sending (pidgintest.2@gmail.com): <starttls xmlns='urn:ietf:params:xml:ns:xmpp-tls'/>
(09:39:53) jabber: Recv (50): <proceed xmlns="urn:ietf:params:xml:ns:xmpp-tls"/>
(09:39:53) nss: Handshake failed  (-12286)

You can find output from the whole run attached.

Version-Release number of selected component (if applicable):
pidgin-2.10.11-8.el7.x86_64


How reproducible:
always

Steps to Reproduce:
1. Open pidgin. Go to Accounts -> Manage accounts and click on Add
2. Choose protocol Google talk. fill username and password, click on remember passwd and click add.
3. 

Actual results:
Connection fails becouse of ssl handshake failed

Expected results:
Account is connected

Additional info:

Comment 4 Petr Schindler 2019-11-19 13:56:30 UTC
There is the same version of pidgin on 7.8 as it is on 7.7 (pidgin-2.10.11-8.el7.x86_64) so this bug still persists.

Comment 5 Debarshi Ray 2020-02-12 13:56:59 UTC
RHEL 7 is approaching its Extended Life Cycle Support phase. Given that this bug isn't present in RHEL 8, and there's no customer case associated with this for RHEL 7, I am inclined to WONTFIX it.

Comment 6 RHEL Program Management 2020-02-12 13:57:05 UTC
Development Management has reviewed and declined this request. You may appeal this decision by using your Red Hat support channels, who will make certain  the issue receives the proper prioritization with product and development management.

https://www.redhat.com/support/process/production/#howto


Note You need to log in before you can comment on or make changes to this bug.