Bug 173327 - PHP session expire too early and/or loose session at creation
PHP session expire too early and/or loose session at creation
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: php (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-16 06:44 EST by Juvenal A. Silva Jr.
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:51:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Juvenal A. Silva Jr. 2005-11-16 06:44:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
This is a random problem. Being said that I'll describe what's happening...
I recompiled the php component as told in BUG#143183 to enable Informix and OCI8 support, and as my application that shows this behavior depends on them, I am unable to test with the plain component as shipped from RedHat. That's what happens:
The sessions created expired at random times, not following the configuration in php.ini. Sometimes it's much too earlier, sometimes too later, but the most important fact is that they don't seems to follow the interactions of the users, since the expiration period is based on lack of user interactivity with the server. Everytime the expiration occurs on some almost constant amount of time, being the user interacting or not with the server. I found no solution nor work-around for this yet.
The second behavior that we got is that sometimes the session doesn't seem to be initialized, but no notice, warning or error is given (I tried using E_ALL error reporting). The most intriguing part is that only some random client machines show this problem (I belive that it's because only some httpd processes were affected). The only thing to do to resolve this issue is to restart the httpd process.

Version-Release number of selected component (if applicable):
php-4.3.2-26.ent.custom

How reproducible:
Didn't try

Steps to Reproduce:


Additional info:
Comment 1 Juvenal A. Silva Jr. 2005-11-22 10:10:32 EST
Any news on this subject??? I'd tried to control the session expiration by hand,
setting a multi level depth for the session storage and putting in cron a script
to clear the files that where last accessed 30 minutes.
The problem is that even with this setting the session expires randomly.
Only to confirm, the session files were generated in the tree hierarchy just
created.
Comment 2 RHEL Product and Program Management 2007-10-19 14:51:02 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.