Bug 173335 - Remove perl-dependency of %doc files
Remove perl-dependency of %doc files
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: boa (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-16 08:30 EST by Enrico Scholz
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.94.14-0.2.rc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-16 11:33:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2005-11-16 08:30:24 EST
Description of problem:

'boa' is a small webserver. At least, it could be a small webserver
when there would not be the %doc files which create deps on 'perl':

| $ rpm -q --filerequire boa-0.94.14-0.1.rc21.i386.rpm
| /usr/share/doc/boa-0.94.14/examples/cgi-test.cgi        /usr/bin/perl perl(POSIX) perl(strict) 
| /usr/share/doc/boa-0.94.14/examples/nph-test.cgi        /usr/bin/perl 
| /usr/share/doc/boa-0.94.14/examples/resolver.pl /usr/bin/perl 

'perl' is not required for core functionality but adds 30-40MB of bloat.
Removing the 'x' filepermission of the %doc files are an easy way to fix this.


Version-Release number of selected component (if applicable):

boa-0.94.14-0.1.rc21
Comment 1 Matthias Saou 2005-11-16 11:33:25 EST
Should be fixed in CVS, and rebuilt soon(-ish, since the build system is
currently down for maintenance). Thanks for spotting this ;-)

Note You need to log in before you can comment on or make changes to this bug.