Bug 1733672 - Leapp upgrade from RHEL7 to RHEL8 failed
Summary: Leapp upgrade from RHEL7 to RHEL8 failed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: leapp-repository
Version: 7.6
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Leapp team
QA Contact: Alois Mahdal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-27 07:19 UTC by kengcc
Modified: 2019-11-27 18:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-27 18:26:21 UTC
Target Upstream Version:


Attachments (Terms of Use)
sosreport (16.87 MB, application/x-xz)
2019-07-27 07:19 UTC, kengcc
no flags Details

Description kengcc 2019-07-27 07:19:31 UTC
Created attachment 1593818 [details]
sosreport

Description of problem:
leapp upgrade failed with the following error:

2019-07-27 15:01:06.813 INFO     PID: 2035 leapp.workflow: Workflow interrupted due to the FailPhase error policy

============================================================
                        ERRORS
============================================================

2019-07-27 15:00:53.428966 [ERROR] Actor: prepare_upgrade_transaction Message:  A Leapp Command Error occurred.

============================================================
                     END OF ERRORS
============================================================


Version-Release number of selected component (if applicable):


How reproducible:
leapp upgrade --debug --verbose |& tee /tmp/$HOSTNAME.leapp.output

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Petr Stodulka 2019-11-27 18:26:21 UTC
The problem is here:
----
  /usr/lib64/libzip.so.5.0 from install of libzip-1.5.1-1.module+el8+2561+1aca3413.x86_64 conflicts with file from package libzip5-1.5.2-1.el7.remi.x86_64
----

The installed libzip5 rpm is not provided by Red Hat. Another problem is that the rpm has higher version than the one in RHEL 8. Downgrade of RPMs is problematic and currently we are not able to handle it. I suggest you to remove the rpm from the system - or replace it by the one provided by RH. We cannot take responsibility for 3rd party content. Another thing what you can do, is to create additional custom actor and provide repository with up-to-date RHEL 8. We do not have official documentation for custom actors and instructions how to extend our current solution, so the upgrade process will be in such case probably unsupported. I cannot tell that for sure, about that, it's better to contact our support. Anyway, if you will create own actors, please test the solution first on non-production environment.

How  to write own actor: https://leapp.readthedocs.io/en/latest/index.html


Note You need to log in before you can comment on or make changes to this bug.