Bug 173393 - SDL_mixer should depend on timidity++
SDL_mixer should depend on timidity++
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: SDL_mixer (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-16 16:22 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-17 10:52:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2005-11-16 16:22:01 EST
SDL_mixer needs /etc/timidity.cfg as well as the timidity instruments in order  
to play MIDI files.  
  
To reproduce: "playmus /path/to/a/file.mid", results:  
 
    Opened audio at 22050 Hz 16 bit stereo, 4096 bytes audio buffer 
    Couldn't load [...]: /etc/timidity.cfg: No such file or directory 
 
If /etc/timidify.cfg is manually created without installing timidity++, the 
error message goes away, but there's still no sound (due to missing 
instruments, I gather). 
 
Installing timidity++ fixes both issues, so IMO SDL_mixer should have a 
dependency on it.  Leaving pulling it in as the responsibility of apps using 
SDL_mixer to play MIDI files would be suboptimal and fragile should SDL_mixer 
for some reason ever be changed to use native (GPL'd) MIDI internally.
Comment 1 Brian Pepple 2005-11-16 16:38:41 EST
Seems reasonable enough.  I should have some time tomorrow to look at this closer.
Comment 2 Brian Pepple 2005-11-17 10:52:15 EST
Added requires for timidity++,  should be available with next push of Fedora
Extra packages.  Thanks for the bug report.
Comment 3 Jens Petersen 2006-08-16 03:29:28 EDT
timidity++ is over 9MBs though... :-/
Comment 4 Jens Petersen 2006-08-16 03:31:10 EDT
but it is in Core.

Note You need to log in before you can comment on or make changes to this bug.