Bug 173401 - cimserver SSL support broke with upgrade to openssl-0.9.8a
cimserver SSL support broke with upgrade to openssl-0.9.8a
Product: Fedora
Classification: Fedora
Component: tog-pegasus (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Depends On: 173399
  Show dependency treegraph
Reported: 2005-11-16 18:04 EST by Jason Vas Dias
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2:2.5-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-22 12:21:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jason Vas Dias 2005-11-16 18:04:45 EST
Description of problem:

openssl-0.9.8a bug 173399 caused cimserver's SSL support to fail for clients 
from openssl-0.9.8a clients:

$ osinfo -s -h localhost -u pegasus
Please enter your password:
osinfo error: Cannot connect to localhost:5989. Connection failed.

whereas the name tog-pegasus-2.5.3 version worked fine when compiled and
run with openssl-0.9.7f.

The tog-pegasus-2.5-3 server running under openssl-0.9.8a serves remote 
SSL clients that use openssl-0.9.7f OK , but cannot serve local 0.9.8a
SSL clients .

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Jason Vas Dias 2005-11-16 18:07:39 EST
tog-pegasus-2.5-4 will disable support for SSLv2 clients. 
When bug 173399 is fixed, SSLv2 support can be re-enabled.

Note You need to log in before you can comment on or make changes to this bug.