Bug 1734127 - routes without <clustername> prefix directly on <basedomain>
Summary: routes without <clustername> prefix directly on <basedomain>
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: DNS
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Dan Mace
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-29 16:45 UTC by mmariyan
Modified: 2019-07-30 13:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-30 13:51:01 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description mmariyan 2019-07-29 16:45:44 UTC
Description of problem:

In ocp 4.x the wildcard routes are creating like ".apps.<clustername>.<basedomain>. when we tried to change this like only to use basedomain .<basedomain>.com in the default ingresscontroller domain its not able to resolve it's creating a new wildcard in the private zone.

> when adding the second"ingress controller with only the basedoamin, This creates a second deployment of the routers, creates a loadbalancer on AWS and tries to create the DNS records on Route53. This works for the public zone (which is automatically set to ".<basedoamin>"), but fails with the internal, private zone because this is set to "clustername.basdoamin".

> now the requirement is all the application should use the subdomain only my domainname not with <clustername>.<domainname>

Ex:
  
 like this 
  ```
  https://console-openshift-console.example1.com 
  ```

not like

 ```
 https://console-openshift-console.apps.myclustername.example1.com

 ```

Version-Release number of selected component (if applicable):

OCP 4.1

How reproducible:


Steps to Reproduce:
1. Install OCP 4.1 Cluster on AWS with openshift-installer
2. After installation `oc edit ingress.config.opneshift.io/cluster`
3. Change spec.domain and remove apps.<clustername>. from it.

Actual results:

its not resolving

Expected results:

it should work as per the change

Additional info:


Note You need to log in before you can comment on or make changes to this bug.