Bug 17342 - Sun E3000 wont cold boot RH 6.2
Sun E3000 wont cold boot RH 6.2
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
sparc Linux
medium Severity high
: ---
: ---
Assigned To: David Miller
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-07 20:58 EDT by Dale Clapperton
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-16 17:59:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Complete copy of boot sequence (8.24 KB, text/plain)
2000-09-07 20:59 EDT, Dale Clapperton
no flags Details

  None (edit)
Description Dale Clapperton 2000-09-07 20:58:04 EDT
Configuration: Sun Enterprise 3000, 2* 166mhz UltraSPARC processors, 
256meg RAM, 1* Seagate ST15230WC, 1* Toshiba XM-5401TASUN4XCD CDROM, 
Redhat Linux 6.2.

Problem: Won't cold boot.  On a cold boot this happens:

[...]
esp0: IRQ 7,db SCSI ID 7 Clk 40MHz CCF=8 TOut 167 NCR53C9XF(espfast)
ESP: Total of 1 ESP hosts found, 1 actually in use.
scsi0 : Sparc ESP366-HME
scsi : 1 host.
esp0: DMA error b2bf8a03
esp0: Resetting scsi bus
esp0: SCSI bus reset interrupt
esp0: DMA error b2bf8a03
esp0: Resetting scsi bus
esp0: SCSI bus reset interrupt
esp0: DMA error b2bf8a03
esp0: Resetting scsi bus
esp0: SCSI bus reset interrupt

And keeps looping endlessly through the above.  After you send it a break 
to get to the openboot console and then do a "boot" from the ok prompt, it 
boots normally as below:

esp0: IRQ 7,db SCSI ID 7 Clk 40MHz CCF=8 TOut 167 NCR53C9XF(espfast)
ESP: Total of 1 ESP hosts found, 1 actually in use.
scsi0 : Sparc ESP366-HME
scsi : 1 host.
  Vendor: SEAGATE   Model: ST15230W SUN4.2G  Rev: 0738
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sda at scsi0, channel 0, id 0, lun 0
  Vendor: TOSHIBA   Model: XM-5401TASUN4XCD  Rev: 1036
  Type:   CD-ROM                             ANSI SCSI revision: 02
Detected scsi CD-ROM sr0 at scsi0, channel 0, id 6, lun 0
scsi : detected 1 SCSI cdrom 1 SCSI disk total.
esp0: target 6 asynchronous
Uniform CDROM driver Revision: 2.56
esp0: target 0 [period 100ns offset 15 20.00MHz FAST-WIDE SCSI-II]
SCSI device sda: hdwr sector= 512 bytes. Sectors= 8386733 [4095 MB] [4.1 
GB]
Partition check:
 sda: sda1 sda2 sda3 sda4 sda5 sda6
md.c: sizeof(mdp_super_t) = 4104
autodetecting RAID arrays
autorun ...

This problem does not occur under SunOS 5.6, which was the previous OS on 
this box, and there have been no configuration changes since then.  The 
problem is reproducable, it happens every single time without fail.  The 
machine is physically located in the Brisbane CBD if someone from the 
Redhat office in Brisbane wants to come take a look at it.
Comment 1 Dale Clapperton 2000-09-07 20:59:53 EDT
Created attachment 3298 [details]
Complete copy of boot sequence
Comment 2 David Miller 2000-09-16 21:55:27 EDT
I don't have any Ex000 systems, so I have no way to fix this.
Sorry.

Note You need to log in before you can comment on or make changes to this bug.