Bug 1734596 - [abrt] module-build-service: build_module_locally(): manage.py:197:build_module_locally:RuntimeError: Module build failed
Summary: [abrt] module-build-service: build_module_locally(): manage.py:197:build_modu...
Keywords:
Status: CLOSED DUPLICATE of bug 1730323
Alias: None
Product: Fedora
Classification: Fedora
Component: module-build-service
Version: 30
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ralph Bean
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:5f8a44165c5e892b7a502dcdec6...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-31 02:18 UTC by Michael Catanzaro
Modified: 2019-07-31 21:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-31 21:11:24 UTC


Attachments (Terms of Use)
File: backtrace (2.06 KB, text/plain)
2019-07-31 02:18 UTC, Michael Catanzaro
no flags Details
File: cgroup (399 bytes, text/plain)
2019-07-31 02:18 UTC, Michael Catanzaro
no flags Details
File: cpuinfo (1.51 KB, text/plain)
2019-07-31 02:18 UTC, Michael Catanzaro
no flags Details
File: environ (5.72 KB, text/plain)
2019-07-31 02:18 UTC, Michael Catanzaro
no flags Details
File: mountinfo (3.90 KB, text/plain)
2019-07-31 02:18 UTC, Michael Catanzaro
no flags Details
File: namespaces (129 bytes, text/plain)
2019-07-31 02:18 UTC, Michael Catanzaro
no flags Details
File: open_fds (1.57 KB, text/plain)
2019-07-31 02:18 UTC, Michael Catanzaro
no flags Details

Description Michael Catanzaro 2019-07-31 02:18:35 UTC
Version-Release number of selected component:
module-build-service-2.25.0-2.fc30

Additional info:
reporter:       libreport-2.10.1
cmdline:        /usr/bin/python3 /usr/bin/mbs-manager build_module_locally --file /home/mcatanzaro/Projects/fedora-flatpaks/epiphany/epiphany.yaml --stream master
crash_function: build_module_locally
exception_type: RuntimeError
executable:     /usr/bin/mbs-manager
interpreter:    python3-3.7.3-3.fc30.x86_64
kernel:         5.1.19-300.fc30.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
manage.py:197:build_module_locally:RuntimeError: Module build failed

Traceback (most recent call last):
  File "/usr/bin/mbs-manager", line 11, in <module>
    load_entry_point('module-build-service==2.25.0', 'console_scripts', 'mbs-manager')()
  File "/usr/lib/python3.7/site-packages/module_build_service/manage.py", line 267, in manager_wrapper
    manager.run()
  File "/usr/lib/python3.7/site-packages/flask_script/__init__.py", line 417, in run
    result = self.handle(argv[0], argv[1:])
  File "/usr/lib/python3.7/site-packages/flask_script/__init__.py", line 386, in handle
    res = handle(*args, **config)
  File "/usr/lib/python3.7/site-packages/flask_script/commands.py", line 216, in __call__
    return self.run(*args, **kwargs)
  File "/usr/lib/python3.7/site-packages/module_build_service/manage.py", line 197, in build_module_locally
    raise RuntimeError("Module build failed")
RuntimeError: Module build failed

Local variables in innermost frame:
local_build_nsvs: None
yaml_file: '/home/mcatanzaro/Projects/fedora-flatpaks/epiphany/epiphany.yaml'
srpms: []
stream: 'master'
skiptests: False
default_streams: []
offline: False
platform_repofiles: []
platform_id: None
confdir: '/home/mcatanzaro/Projects/fedora-flatpaks/epiphany'
dbdir: '/home/mcatanzaro/Projects/fedora-flatpaks/epiphany'
dbpath: '//home/mcatanzaro/Projects/fedora-flatpaks/epiphany/.mbs_local_build.db'
dburi: 'sqlite:////home/mcatanzaro/Projects/fedora-flatpaks/epiphany/.mbs_local_build.db'
params: {'local_build': True, 'default_streams': {}}
username: 'mcatanzaro'
yaml_file_path: '/home/mcatanzaro/Projects/fedora-flatpaks/epiphany/epiphany.yaml'
fd: <_io.TextIOWrapper name='/home/mcatanzaro/Projects/fedora-flatpaks/epiphany/epiphany.yaml' mode='r' encoding='UTF-8'>
filename: 'epiphany.yaml'
handle: <FileStorage: 'epiphany.yaml' (None)>
modules_list: [<ModuleBuild epiphany, id=2, stream=master, version=3020190731015223, scratch=False, state 'failed', batch 2, state_reason 'Component(s) libhandy failed to build.'>]
stop: <function make_simple_stop_condition.<locals>.stop_condition at 0x7f537185f6a8>

Comment 1 Michael Catanzaro 2019-07-31 02:18:38 UTC
Created attachment 1594892 [details]
File: backtrace

Comment 2 Michael Catanzaro 2019-07-31 02:18:39 UTC
Created attachment 1594893 [details]
File: cgroup

Comment 3 Michael Catanzaro 2019-07-31 02:18:40 UTC
Created attachment 1594894 [details]
File: cpuinfo

Comment 4 Michael Catanzaro 2019-07-31 02:18:41 UTC
Created attachment 1594895 [details]
File: environ

Comment 5 Michael Catanzaro 2019-07-31 02:18:42 UTC
Created attachment 1594896 [details]
File: mountinfo

Comment 6 Michael Catanzaro 2019-07-31 02:18:43 UTC
Created attachment 1594897 [details]
File: namespaces

Comment 7 Michael Catanzaro 2019-07-31 02:18:44 UTC
Created attachment 1594898 [details]
File: open_fds

Comment 8 Matt Prahl 2019-07-31 21:04:01 UTC
What is the issue exactly? Was the component build that failed which caused the module build to fail not supposed to fail?

Comment 9 Michael Catanzaro 2019-07-31 21:11:24 UTC
(In reply to Matt Prahl from comment #8)
> What is the issue exactly? Was the component build that failed which caused
> the module build to fail not supposed to fail?

No, it failed for a valid reason. The problem is module-build-service should not throw a python exception for build failures, because that results in ABRT bug reports. :) Instead, it should catch the exception and print some normal error message to avoid generating spurious bug reports against module-build-service.

*** This bug has been marked as a duplicate of bug 1730323 ***


Note You need to log in before you can comment on or make changes to this bug.