Bug 17347 - Mouse configuration for Microsoft 2 Button serial mouse
Mouse configuration for Microsoft 2 Button serial mouse
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i386 Linux
low Severity low
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-08 04:01 EDT by astacey
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-05 11:14:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description astacey 2000-09-08 04:01:23 EDT
I have a 2 Button Microsoft serial mouse.  The RedHat 6.2 installation
inserted the following lines into XF86Config (amongst others):

Protocol "Microsoft"
Buttons 2
Emulate3Buttons

This produced the following effect: When using the mouse, I could use
button 1 (left click) and button 2 (left+right click) but not button 3
(right click).

Removing the line 'Buttons 2' solved the problem.  Thus it appears to be
a problem within X which confuses the actual number of buttons with the
emulated number of buttons.

I have submitted this bug to the XFree86 development team, but would
respectfully suggest that the RH install script should be altered to
take this into account, or a note should be clearly made in the
documentation.
Comment 1 Michael Fulbright 2000-12-21 14:33:14 EST
I believe we have corrected this issue in Red Hat Linux 7.0, assigning to a
developer to verify.
Comment 2 Brent Fox 2001-02-09 04:57:16 EST
Brock, you've done some recent testing with serial mice.  What's the status of them?
Comment 3 Brent Fox 2001-02-17 00:05:21 EST
Apparently, this is still broken.
Comment 4 Michael Fulbright 2001-03-01 14:12:27 EST
Against wolverine?
Comment 5 Brent Fox 2001-03-05 11:14:05 EST
Seems to be working now with the latest internal builds.

Note You need to log in before you can comment on or make changes to this bug.