Bug 17353 - ACCT-passwort in netrc is not used
Summary: ACCT-passwort in netrc is not used
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ftp   
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-08 11:19 UTC by henrik.seidel
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-08 11:20:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the fix for the ACCT-password/netrc bug (449 bytes, patch)
2000-09-08 11:20 UTC, henrik.seidel
no flags Details | Diff

Description henrik.seidel 2000-09-08 11:19:24 UTC
Hi,
 
there seems to be a bug in the ftp program. The "account VALUE" entry in
netrc
files is not actually used. This is a problem for certain types of
firewalls
which expect
 
USER remote_user firewall_user
PASS remote_passw
ACCT firewall_passw
 
Currently, the ftp program does not use the "account" field in the login
procedure but the user is always prompted for the "Account:" password. This
disables batch jobs using ftp.
 
The fix is attached.
 
Best regards
 
Henrik Seidel

diff -Naur netkit-ftp-0.16.orig/ftp/ftp.c netkit-ftp-0.16/ftp/ftp.c
--- netkit-ftp-0.16.orig/ftp/ftp.c      Mon Dec 13 20:33:20 1999
+++ netkit-ftp-0.16/ftp/ftp.c   Fri Sep  8 10:55:54 2000
@@ -253,8 +253,10 @@
        }
        if (n == CONTINUE) {
                aflag++;
-               /* fflush(stdout); */
-               zacct = getpass("Account:");
+               if (zacct == NULL) {
+                       /* fflush(stdout); */
+                       zacct = getpass("Account:");
+               }
                n = command("ACCT %s", zacct);
        }
        if (n != COMPLETE) {

Comment 1 henrik.seidel 2000-09-08 11:20:32 UTC
Created attachment 3318 [details]
This is the fix for the ACCT-password/netrc bug

Comment 2 Bernhard Rosenkraenzer 2001-01-21 00:01:29 UTC
Thanks, fixed in 0.17-7


Note You need to log in before you can comment on or make changes to this bug.