Bug 173582 - Addendum RE GRUB Change Drive Order
Addendum RE GRUB Change Drive Order
Status: CLOSED RAWHIDE
Product: Fedora Documentation
Classification: Fedora
Component: install-guide (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stuart Ellis
Paul W. Frields
http://webtest.fedora.redhat.com/docs...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-18 06:51 EST by David Niemi
Modified: 2007-04-18 13:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-01 19:21:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Niemi 2005-11-18 06:51:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Section 7.4 Advanced Boot Loader Options

I think it would be good to include a statement about the change drive order.  Something to the effect of:

You may need to confirm or change the drive booting order with the Change Drive Order if you change the boot order in the BIOS to boot into Linux.  This is important on multi-boot / multi-harddrive systems to ensure GRUB will not be confused by different BIOS settings when the system is booted into Linux.



Version-Release number of selected component (if applicable):
rawhide

How reproducible:
Always

Steps to Reproduce:
1. Not applicable
2.
3.
  

Additional info:

A link to additional information on experienced GRUB problems and solutions would also be of great assistance to many new users who will not understand many of the cryptic GRUB error messages.
Comment 1 Stuart Ellis 2005-11-19 10:04:18 EST
Could you give an example of how this works out in practice (i.e. the steps and
the end goal) ? I've used VMs for multi-OS systems rather than dual-boot for a
long time, so I personally haven't much experience of multi-boot + multi-drive.

WRT a link to GRUB documentation for troubleshooting, I have previously thought
about having a set of links at the end for the various systems that anaconda
exposes to the user, and will implement something for the next test release. I'm
generally not in favor of adding links to the main text because 9/10 of users
don't need the info, and it adds an extra decision point (i.e. "Should I carry
on, or break off to read yet another document ?").
Comment 2 David Niemi 2006-01-22 08:17:48 EST
(In reply to comment #1)
> Could you give an example of how this works out in practice (i.e. the steps 

If someone has hda and hdb and used the BIOS to select hdb as the primary drive
for doing the install (safety), though installed grub to the boot sector of hda
and after the install selected hda in the BIOS as the primary boot drive.  This
would cause grub to be confused about the drive order.  This often happens with
multiple versions or OS's. (This is my understanding and there probably is many
others reasons for this, I consider myself still climbing the knowledge gap
mountain)

The Install guide could perhaps mention the advance options prior to moving on
to discussing them on a new page, kind of following the install process.  If you
didn't select the option you'd never get to what is displayed under Section 7.4.
Kind of like someone actually following the install guide while installing
step-by-step.
> WRT a link to GRUB documentation for troubleshooting, I have previously 
< SNIP >
> don't need the info, and it adds an extra decision point (i.e. "Should I carry
> on, or break off to read yet another document ?").

Agreed, it was a thought. I was just thinking of when FC4 came out there were
many posts with similar problems with GRUB on the mailing list and the forum and
if there were some links given up front or perhaps a documentation project
document listed it could head off some of these repeats. This would be good for
new people and hopefully reduce their being put off by the curt "search the
list" answers.
Comment 3 Stuart Ellis 2006-02-01 19:21:14 EST
Thanks, that was helpful.

I've amended the text of the Boot Loader chapter - the latest version of the
draft FC5 IG (1.17) now mentions the advanced options screen in advance, and the
section on advanced option is hopefully now clearer on changing the drive order.

The FC5 IG also has a Technical References appendix to aggregate links to useful
documentation. The GRUB item currently links to the GRUB project webpage, but
this can be changed to point the user somewhere else if there is a better source
of information available.

We are currently working on a FAQ and other website content, so if you'd like to
write something up on GRUB, please do send a mail to the documentation list.

Note You need to log in before you can comment on or make changes to this bug.