Bug 173589 - "Error creating feature" dialog pops up when accessing Update Manager
"Error creating feature" dialog pops up when accessing Update Manager
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-18 08:46 EST by Robin Green
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.1.1-1jpp_1fc.FC4.11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-04 15:15:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2005-11-18 08:46:45 EST
Description of problem:
When I go to access the update manager, I get a couple of error dialogs about
missing features. This appears to prevent me installing new features using the
update manager.

Version-Release number of selected component (if applicable):
eclipse-platform-3.1.1-1jpp_1fc.FC4.4

How reproducible:
Always

Steps to Reproduce:
1. Help menu -> Software Updates -> Find and Install
  
Actual results:
Dialog box pops up twice, saying:

Error creating feature:
"file:/usr/share/eclipse/features/org.eclipse.jdt.source_3.1.1/".
[/usr/share/eclipse/features/org.eclipse.jdt.source_3.1.1/ (No such file or
directory]

Expected results:
No error

Additional info:
"rm -rf .eclipse workspace" and trying again does not make any difference
Comment 1 Andrew Overholt 2005-11-18 09:37:28 EST
This is actually because you don't have eclipse-jdt-devel and/or
eclipse-rcp-devel and/or other *-devel packages installed.  Try installing those
and see if it fixes it.
Comment 2 Robin Green 2005-11-18 10:28:20 EST
I had to install eclipse-jdt-devel, eclipse-rcp-devel and eclipse-pde-devel.
But it shouldn't be necessary to install all these packages.
Comment 3 Andrew Overholt 2005-11-18 10:31:59 EST
(In reply to comment #2)
> I had to install eclipse-jdt-devel, eclipse-rcp-devel and eclipse-pde-devel.
> But it shouldn't be necessary to install all these packages.

Why not?  Eclipse is trying to validate that it has the contents of those
packages and it's throwing an error otherwise.

Perhaps there's something wrong with our MANIFEST.MF files or something? 
Patching those to be relevant to just subsets of the SDK sounds like a nightmare
to me.  The Update Manager in general causes a lot of problems for us ...
Comment 4 Robin Green 2005-11-18 10:41:02 EST
> Why not?

Well, simply because there's no point in separating eclipse into separate
packages if you end up (pointlessly) having to install (nearly) all of them in
all cases.
Comment 5 Andrew Overholt 2005-11-18 10:45:56 EST
(In reply to comment #4)
> > Why not?
> 
> Well, simply because there's no point in separating eclipse into separate
> packages if you end up (pointlessly) having to install (nearly) all of them in
> all cases.

While I agree, I'll have to spend some time working on this to figure out a
solution.  Does the update manager absolutely not work if you don't have these
packages installed?
Comment 6 Robin Green 2005-11-18 11:25:50 EST
(In reply to comment #5)
> Does the update manager absolutely not work if you don't have these
> packages installed?

No, it doesn't. It refuses to install a feature (SchemeWay) which installs fine
after I installed those packages, so it's not a problem with the feature I was
trying to install. It just gives some generic error about "configuration
problem" and grays out the Finish button.
Comment 7 Andrew Overholt 2005-12-05 16:53:30 EST
I spent some time looking into this today.  It appears that the problem is that
the platform configuration xml file lists the source features as sub-features
like this:

/usr/share/eclipse/configuration/org.eclipse.update/platform.xml
================================================================
...
<feature id="<blah>" version="3.1.1" url="features/<blah>_3.1.1/">
</feature>
...

There is also mention of these features in the SDK feature.xml:

/usr/share/eclipse/features/org.eclipse.sdk_3.1.1/feature.xml
=============================================================
...
<includes id="blah" version="3.1.1"/>
...

At this point I'm thinking we'll need some sort of script that merges SDK
features into these two files in their respective %post sections.  Thoughts?
Comment 8 Andrew Overholt 2005-12-08 10:23:15 EST
I've built packages for both rawhide (eclipse-3.1.1-1jpp_9fc) and FC4
(eclipse-3.1.1-1jpp_1fc.FC4.8 ... will appear in updates-testing at some point
today) that contain my proposed fix.  When you get a chance, please test these
to see if they fix this problem.  Thanks.
Comment 9 Ben Konrath 2006-01-04 15:15:12 EST
This is fixed in testing-updates with version
eclipse-platform-3.1.1-1jpp_1fc.FC4.11.

Note You need to log in before you can comment on or make changes to this bug.