Bug 173639 - Suspend and Hibernate from GPM menu do nothing
Suspend and Hibernate from GPM menu do nothing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-18 14:25 EST by Bernard Johnson
Modified: 2013-03-13 00:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-09 18:20:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hald output (144.90 KB, text/plain)
2005-11-19 13:46 EST, Bernard Johnson
no flags Details
gnome-power-manager output (4.57 KB, text/plain)
2005-11-19 13:46 EST, Bernard Johnson
no flags Details

  None (edit)
Description Bernard Johnson 2005-11-18 14:25:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051103 Fedora/1.5-0.5.0.rc1 Firefox/1.5

Description of problem:
My notebook (Hewlett Packard ZD7000 CTO) will both suspend and hibernate when one of the following commands are executed:

echo "mem" > /sys/power/state
 or
echo "disk" > /sys/power/state

Clicking Suspend or Hibernate on the GPM menu cause the screensaver to activate and nothing else.

Version-Release number of selected component (if applicable):
gnome-power-manager-0.2.8-1

How reproducible:
Always

Steps to Reproduce:
1.  Click Suspend or Hibernate from GPM menu.
2.  Notice screensaver activates but nothing else.
3.
  

Expected Results:  Computer should suspend or hibernate.

Additional info:

rpm -q hal dbus
hal-0.5.5.1-1
dbus-0.50-1

Nothing is logged by syslog - not that I've been able to find anyway.  I see a new version of GPM (0.3) is released upstream.  Maybe it will work.
Comment 1 Richard Hughes 2005-11-19 06:49:01 EST
Can you please attach a HAL debug trace (information here:
http://www.gnome.org/projects/gnome-power-manager/bugs.html) when you try to
suspend or hibernate. Also, what version of pm-utils have you got installed?
Many thanks, Richard.
Comment 2 Bernard Johnson 2005-11-19 13:46:01 EST
Created attachment 121267 [details]
hald output
Comment 3 Bernard Johnson 2005-11-19 13:46:59 EST
Created attachment 121268 [details]
gnome-power-manager output
Comment 4 Bernard Johnson 2005-11-19 13:51:48 EST
Ok, you're going to love this.  When I try to hibernate after the system is
started, it fails every time.  If I kill hald and then start hald and
gnome-power-manager as directed on the bugs page, it works flawlessly every
time. I've attached the hald and gnome-power-manager output anyway, although
it's probably useless because it succeded every time I captured the output.

I also upgraded to todays rawhide pm-utils (pm-utils-0.06-3) and it had not
effect on either scenario.

Recommended additional data:
[root@localhost ~]# for i in /proc/acpi/battery/*/*; do echo $i; cat $i; done
/proc/acpi/battery/BAT1/alarm
alarm:                   unsupported
/proc/acpi/battery/BAT1/info
present:                 yes
design capacity:         6450 mAh
last full capacity:      1984 mAh
battery technology:      rechargeable
design voltage:          14800 mV
design capacity warning: 300 mAh
design capacity low:     200 mAh
capacity granularity 1:  32 mAh
capacity granularity 2:  32 mAh
model number:            02NT
serial number:           10513
battery type:            LION
OEM info:                DYNA-SON
/proc/acpi/battery/BAT1/state
present:                 yes
capacity state:          ok
charging state:          charged
present rate:            0 mA
remaining capacity:      1984 mAh
present voltage:         16576 mV
[root@localhost ~]#

Comment 5 Richard Hughes 2005-11-19 15:58:12 EST
Okay... I'm at loss to explain that!

Can you try getting some debug data from the startup created hald by changing
/etc/init.d/haldaemon from:
    daemon --check $servicename $processname --retain-privileges
to
    daemon --check $servicename $processname --retain-privileges --use-syslog

and then configuring syslog to catch the new stuff.
Also, are you running SELinux?
Comment 6 Bernard Johnson 2005-11-19 21:35:13 EST
I AM running SELinux (targeted-enforcing) and it does seem to make a difference.
 If I change SELinux to permissive, the system will hibernate.  If we are to go
on the assumption that something is being denied when run with enforcing - why
don't I see it in syslog?
Comment 7 Richard Hughes 2005-11-20 05:33:27 EST
Have you tried adding the extra stuff here?
http://www.gnome.org/projects/gnome-power-manager/faq.html#hald_selinux
Altho it should show up in the SELinux log file as denied. Might be worth
buzilla'ing the selinux component.
Comment 8 Bernard Johnson 2005-12-07 23:35:30 EST
Recent updates to rawhide have resolved this issue, although I'm not sure how or
why.
Comment 9 Bernard Johnson 2005-12-08 01:04:37 EST
Well, almost.

Occasionally, I do a selinux relabel.  I did it with this last update as well. 
After the relabel, hibernate works perfectly.  After I reboot however, it's back
to the same behavior as before.

Please note, this is an advancement from the previous situation, because I had
tried relabel several times.

To answer comment #7 - no, I haven't changed my selinux policy, I'm just running
the stock policy.

I'm guessing that this is almost certainly a selinux issue now, given the recent
behavior.

Any ideas?
Comment 10 Richard Hughes 2005-12-08 04:28:13 EST
Urm.. It soulds like hald and selinux are not playing nicely. What selinux
denied messages do you get when running hald in restrictive mode? Might be worth
starting a bug for the selinux-policy component so it gets seen by some selinux
guys.
Comment 11 Bernard Johnson 2005-12-09 18:05:17 EST
Todays rawhide update resolved this completely.  I've tested it a half dozen
times or so now across multiple reboots and haven't seen any of the previous
symptoms.
Comment 12 John (J5) Palmieri 2005-12-09 18:20:36 EST
Of course ultimately we want to take this out once Hybernate and Suspend are
working good on most laptops.  The idea is many people don't know what they are
(and the shouldn't have to know).  I even get confused which one is which so
seeing them in the UI sucks.  Ultimately if I shut my lid the laptop should
hybernate and after a certaint amount of time or battery charge it should wake
up and then suspend itself to swap.  But I digress and this bug can be closed.

Note You need to log in before you can comment on or make changes to this bug.