Bug 17364 - pump should set DHCP option 60 (vendor class id)
pump should set DHCP option 60 (vendor class id)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: dhcpcd (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
http://faqs.org/rfcs/rfc2132.html
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-08 12:50 EDT by Patrick J. LoPresti
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-20 12:26:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick J. LoPresti 2000-09-08 12:50:46 EDT
RFC 2132 defines DHCP option 60 as the "vendor class identifier".  This is
a string which clients present with their DHCP requests which allow the
DHCP server to decide network configuration based on the client
configuration.

For example, all versions of Microsoft Windows present a vendor class id
which begins with the string "MSFT".  This allows a dhcp server to set the
IP address and other options based on the operating system of the client.

We need this here, because we want to provide our Linux clients with
kickstart information and addresses assigned from a different range than
our other boxes.  But since pump does not present a vendor class ID, the
only way we can do this is to manually enter all the MAC addresses of our
Linux clients, which is really painful.

I don't care what vendor ID pump uses, as long as I can use it to
distinguish Linux clients from other clients.  Other people might want
finer granularity, but the basic functionality (using "PUMP" or "RHAT", for
example) would be trivial to implement and very useful...
Comment 1 Elliot Lee 2001-07-20 00:33:08 EDT
Apologies for the unresponsiveness of the previous pump packager...

dhcpcd has replaced pump in rawhide - does dhcpcd do what you need?
Comment 2 Patrick J. LoPresti 2001-07-20 11:59:41 EDT
I am pretty sure dhcpcd allows you to configure any DHCP client option you like.
So this does fix the problem for assigning different network options after the
client is installed.

However, for kickstart purposes, it would be nice if Red Hat's default dhcpcd
configuration (during installation) included a recognizable vendor ID.  If you
are interested, I can dig up exactly how to configure dhcpcd and give you a more
specific suggestion.

I cannot believe you guys are ditching pump :-).
Comment 3 Elliot Lee 2001-07-20 12:17:52 EDT
Err, my mistake - pump will still be used in the installer due to size constraints.

pump currently uses a vendorCookie of {99, 130, 83, 99, 255} - is that
sufficient to let you do what you need?
Comment 4 Patrick J. LoPresti 2001-07-20 12:26:50 EDT
If by "vendorCookie" you mean DHCP option 60, then yes...  Should I check the
current pump source code to make sure?

Just out of curiosity, why those particular numbers?
Comment 5 Elliot Lee 2001-08-07 23:41:51 EDT
No clue why those numbers, but apparently this issue is resolved. :)

Note You need to log in before you can comment on or make changes to this bug.