Bug 173696 - udev inicialization is very slow
udev inicialization is very slow
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-18 17:37 EST by Adam Pribyl
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-21 02:29:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Pribyl 2005-11-18 17:37:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.7.11) Gecko/20050728

Description of problem:
Udev inicialization as it is in FC3-4 extremely slows down boot especialy on old hardware (Pentium 233), but the inicialition is the longest part even with the modern hardware.

Version-Release number of selected component (if applicable):
any

How reproducible:
Always

Steps to Reproduce:
1. Use some old hardware
2. Reboot
3.
  

Actual Results:  The udev start is taking tenth of seconds, the rest of boot is pretty fast compared to this.

Additional info:

This is only about to point to weak boot speed up point.

I am not very familiar with udev design, but I noticed that with self compiled, optimized kernel, inicialization is faster - this is because there is not so many modules to probe at boot.
Udev is fine for hotplugable devices, but its usage as is it now for "static" devices, that are in desktop computer initialzed on every boot it's not the best option.

The only way I can now thing of to improve its performace is to apply some kind of caching of modules (I do not mean readahead) that are applicable for machine and rest probe at background.
I mean - store at shutdown used modules, then probe only these at boot, then background.

Maybe there are some other options for udev startup enhancement (dev.d?).
Comment 1 Harald Hoyer 2005-11-21 02:29:02 EST
there were some improvements in recent udev versions... try rawhide and the
latest udev and kernel

Note You need to log in before you can comment on or make changes to this bug.