Bug 173720 - udev need Requires on compatible kernel
udev need Requires on compatible kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-19 10:32 EST by John Ellson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-23 06:21:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2005-11-19 10:32:59 EST
Description of problem:
udev-0.75-2 is incompatible with kernel-2.6.14-1.1632_FC5
and so should have a requires on some later kernel.
Symptoms, startx fails because graphics drivers won't load.

udev-075-2 works with kernel-2.6.14-1.1688_FC5, except that v4l drivers
are broken.  Ref bug# 172379

udev-075-1 works with kernel-2.6.14-1.1632_FC5 which was the last kernel with
working v4l drivers.

Version-Release number of selected component (if applicable):
udev-075-2

How reproducible:
100%

Steps to Reproduce:
1. install kernel-2.6.14-1.1632_FC5 and udev-075-2
2. startx
3.
  
Actual results:
no mouse driver, no graphics driver

Expected results:
udev rpms should not install with incompatible kernels


Additional info:
Comment 1 John Ellson 2005-11-19 10:51:10 EST
A "Requires" still wouldn't completely fix the problem  The newer kernel must
actually be running, not just installed.
Comment 2 Harald Hoyer 2005-11-21 07:13:42 EST
Could you please try the version from ftp://people.redhat.com/harald/udev/075-4/
Comment 3 John Ellson 2005-11-21 08:15:38 EST
Fixes the problem with kernel-2.6.14-1.1632_FC5.  X starts and tvtime works.

OK with kernel-2.6.14-1.1688_FC5 on i686 and x86_64. X starts.

(Still no tvtime on kernel-2.6.14-1.1688_FC5, but I assume thats a different
problem)


Thanks.
Comment 4 G.Wolfe Woodbury 2005-11-21 21:28:49 EST
I'm having trouble getting the test rpm installed.
I go in with the rescue mode and try to rpm -Uvh ....
but get an error unpacking /etc/dev.d and the rpm fails to install.
rawhide of 2005-11-21 doesn't do any better for my video problems.

Note You need to log in before you can comment on or make changes to this bug.