Bug 173738 - Unsatisified dependencies for "system-config-printer-gui"
Summary: Unsatisified dependencies for "system-config-printer-gui"
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-20 09:19 UTC by Joachim Frieben
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-20 21:12:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joachim Frieben 2005-11-20 09:19:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051018 Epiphany/1.8.2

Description of problem:
After a fresh install from the rawhide development tree,
"system-config-printer-gui" crashes instantaneously. The
required module "bonobo.ui" is missing. The exact message
after launching the utility from the command line reads:

[test]$ system-config-printer-gui
ImportError: could not import bonobo.ui

Version-Release number of selected component (if applicable):
anaconda-10.90.5-1.1

How reproducible:
Always

Steps to Reproduce:
1. Execute "system-config-printer-gui" from the shell.
 

Actual Results:  The "system-config-printer-gui" utility flashes up
briefly and that's it.

Expected Results:  One should be able to install a new printer.

Additional info:

After installing the missing "gnome-python2-bonobo" package,
everything works as expected. The strange thing is that
"system-config-printer-gui" requires "gnome-python2" which
itself requires "gnome-python2-bonobo". However, this
dependency was not respected during the installation.

Comment 1 Joachim Frieben 2005-11-20 13:35:00 UTC
Installing "gnome-python2-bonobo" also made "up2date-gnome" usable
again which would not even flash up on the display. This probably
applies to most/all other "GNOME/Python" based utilities.

Comment 2 Jeremy Katz 2005-11-20 17:44:05 UTC
It looks like this is just being caused by a backwards handling of dependency
whiteout.  I've committed a fix for that to CVS.  If you don't mind, could you
run 'rpm -Va 2>&1 |grep Unsat' and let me know any others so that I can ensure
that they're being caused by whiteout as well and that there's not something
else hiding here?

Comment 3 Joachim Frieben 2005-11-20 20:45:36 UTC
Unsatisfied dependencies also for:

  1. ypbind-1.17.2-5.i386: yp-tools
  2. gtk+-1.2.10-48.i386: gdk-pixbuf >= 0.18.0

Comment 4 Jeremy Katz 2005-11-20 21:12:47 UTC
Both of those are also in the whiteout, so should be fixed now.

Thanks for the quick feedback!


Note You need to log in before you can comment on or make changes to this bug.