Bug 173740 - loadavg always above 2...
loadavg always above 2...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-20 04:36 EST by Thomas M Steenholdt
Modified: 2015-01-04 17:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-02 18:30:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas M Steenholdt 2005-11-20 04:36:23 EST
Description of problem:

It looks like, for whatever reason, loadavg adds 2 to the real runqueue average
numbers. On my completely idle system, /proc/loadavg reports 2.00 2.00 2.00.

Other than that loadavg appears to work, increasing with load and dropping again
after removing load.

This is on a Pentium M system.

The last kernel checked was kernel-2.6.14-1.1688_FC5 which still exhibited this
problem.

I have no idea how deep this goes, but i'm guessing that at least some userspace
utils will misbehave because of this.

How reproducible:
always

Steps to Reproduce:
1. cat /proc/loadavg
  
Actual results:

2.xx 2.xx 2.xx ...

Expected results:

0.xx 0.xx 0.xx ...
Comment 1 Dave Jones 2005-12-01 14:56:54 EST
can you attach the output of ps ax please ?
Comment 2 Thomas M Steenholdt 2005-12-02 03:51:31 EST
Problem does not seem to occur after I have updated to test1. Fact is that I did
not check for any stuck process, so that would explain this phenomenon.
Comment 3 Dave Jones 2005-12-02 18:30:22 EST
ok, reopen if it reoccurs.

Note You need to log in before you can comment on or make changes to this bug.