Bug 1737435 - dracut syslog module broken (Debian hardcadded lib path)
Summary: dracut syslog module broken (Debian hardcadded lib path)
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dracut
Version: 6.10
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-05 11:20 UTC by Olivier LAHAYE
Modified: 2019-08-06 14:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-05 11:27:48 UTC


Attachments (Terms of Use)

Description Olivier LAHAYE 2019-08-05 11:20:35 UTC
Description of problem:
/usr/share/dracut/modules.d/98syslog/install is broken line 3: it uses Debian hardcoded library path instead of smarted lib path.
Module tries to find libs in /usr/lib/rsyslog instead of /usr/lib64/rsyslog

Version-Release number of selected component (if applicable):
[root@967ba29cc6ce 51systemimager]# dracut --force --add syslog /tmp/initrd.img 2.6.32-754.17.1.el6.x86_64
network shutdown i18n crypt syslog
E: Failed to install /usr/lib/rsyslog/lmnet.so

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
E: Failed to install /usr/lib/rsyslog/lmnet.so

Expected results:
No failure

Additional info:
Use same approach as dmraid module to fix the issue

Comment 2 Lukáš Nykrýn 2019-08-05 11:27:48 UTC
rhel6 is now in its last maintenance phase and we only fix critical issues.  would suggest upgrading to rhel7 or 8, where you will not have to deal with these issues since logs from early boot are stored in journald by default.

Comment 3 Olivier LAHAYE 2019-08-06 10:10:07 UTC
(In reply to Lukáš Nykrýn from comment #2)
> rhel6 is now in its last maintenance phase and we only fix critical issues. 
> would suggest upgrading to rhel7 or 8, where you will not have to deal with
> these issues since logs from early boot are stored in journald by default.

Problem is that I'm not using rhel6, I'm system imager developper and need to support Rhel-6 as per request of many users.
Systemimager supports all major distort including newer rhel-8 and old centos-6.
Systemimager uses dracut specially crafted module to image a computer from a PXE boot. Imaging need logging. Up to now, it was done manually, but I wanted to enhance logging with a rsylog json I could parse in the same way I do for journald.

See it here in action: https://github.com/finley/SystemImager/wiki/ScreenShots

It's so easy to fix this module. Even more frustrating is that it's fixed in Rhel-7 while being useless (systemd)

Comment 4 Lukáš Nykrýn 2019-08-06 14:54:50 UTC
Well, while it is easy to fix the code, it is not that easy to release the fix in rhel6.

If you and/or your users have a Red Hat account, please file this request in our customer portal, it might increase the chance that anything will be fixed. Otherwise, any change in rhel6 is a no-go.


Note You need to log in before you can comment on or make changes to this bug.