Bug 173775 - crash in help after Edit menu (because can't find documentation?)
crash in help after Edit menu (because can't find documentation?)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
: 173809 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-20 17:52 EST by Andrew
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.0.1-143.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-05 04:03:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew 2005-11-20 17:52:28 EST
Description of problem:
A crash

Version-Release number of selected component (if applicable):
openoffice.org-calc-2.0.0-3.2.1
openoffice.org-core-2.0.0-3.2.1
openoffice.org-draw-2.0.0-3.2.1
openoffice.org-graphicfilter-2.0.0-3.2.1
openoffice.org-impress-2.0.0-3.2.1
openoffice.org-javafilter-2.0.0-3.2.1
openoffice.org-math-2.0.0-3.2.1
openoffice.org-pyuno-2.0.0-3.2.1
openoffice.org-writer-2.0.0-3.2.1
openoffice.org-xsltfilter-2.0.0-3.2.1


How reproducible:
Every time

Steps to Reproduce:
1. Open Writer
2. Click on the Edit menu 
3. Type < ESC > (/partially/ closes the menu)
4. Press F1 (to open help)
  
Actual results:
0x285028: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e028
0x2857ee: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e7ee
0x248420:  + 0x420 (__kernel_sigreturn + 0x0)
0x20b9c27: /usr/lib/openoffice.org2.0/program/libucpchelp1.so + 0x2ac27
0x20b9ef3: /usr/lib/openoffice.org2.0/program/libucpchelp1.so + 0x2aef3
0x20ac418: /usr/lib/openoffice.org2.0/program/libucpchelp1.so + 0x1d418
0x4accba: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x1ccba
0x4af3e3: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x1f3e3
(ucb::Content::openStream() + 0xe9)
0x6bc434: /usr/lib/openoffice.org2.0/program/libcomphelp4gcc3.so + 0x67434
0x6bccc6: /usr/lib/openoffice.org2.0/program/libcomphelp4gcc3.so + 0x67cc6
(comphelper::MediaDescriptor::addInputStream() + 0x1d6)
0x65f435e: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x10c35e
0x65f4921: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x10c921
(SfxMedium::GetInStream() + 0x9d)
0x66161ca: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x12e1ca
(SfxObjectShell::DoLoad(SfxMedium*) + 0x588)
0x6645079: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x15d079
(SfxBaseModel::load(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue>
const&) + 0x2f9)
0x6660d47: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x178d47
0x5d1531b: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xe931b
0x5d154d9: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xe94d9
0x5d15592: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xe9592
0x5c7f406: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x53406
0x65d48e3: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xec8e3
0x65b1a07: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xc9a07
0x9f5f64: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x191f64
0x9f7cb2: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x193cb2
0xa38987: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d4987
0xa3a0ab: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d60ab
0xe7ba88: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x28a88
0xe79b8b: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x26b8b
0xe7af09: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x27f09
0x39c501c: /usr/lib/libgtk-x11-2.0.so.0 + 0x11601c
0xf51b38: /usr/lib/libgobject-2.0.so.0 + 0x8b38 (g_closure_invoke + 0x11e)
0xf60173: /usr/lib/libgobject-2.0.so.0 + 0x17173
0xf61523: /usr/lib/libgobject-2.0.so.0 + 0x18523 (g_signal_emit_valist + 0x41e)
0xf61b23: /usr/lib/libgobject-2.0.so.0 + 0x18b23 (g_signal_emit + 0x29)
0x3aa719f: /usr/lib/libgtk-x11-2.0.so.0 + 0x1f819f
0x39c3869: /usr/lib/libgtk-x11-2.0.so.0 + 0x114869 (gtk_propagate_event + 0x1d3)
0x39c3b90: /usr/lib/libgtk-x11-2.0.so.0 + 0x114b90 (gtk_main_do_event + 0x325)
0xec71f4: /usr/lib/libgdk-x11-2.0.so.0 + 0x3e1f4
0x2f086be: /usr/lib/libglib-2.0.so.0 + 0x246be (g_main_context_dispatch + 0x1dc)
0x2f0b6c6: /usr/lib/libglib-2.0.so.0 + 0x276c6
0x2f0bba8: /usr/lib/libglib-2.0.so.0 + 0x27ba8 (g_main_context_iteration + 0x66)
0xe6bbcf: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x18bcf
0xfcbafa: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x45afa
(X11SalInstance::Yield(unsigned char) + 0x28)
0x8ec594: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x88594
(Application::Yield() + 0x48)
0x8ec5ca: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x885ca
(Application::Execute() + 0x26)
0x5726c73: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x21c73
(desktop::Desktop::Main() + 0x15ab)
0x8f199f: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8d99f
0x8f1a4f: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8da4f (SVMain()
+ 0x29)
0x5721ad7: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1cad7 (sal_main
+ 0x57)
0x5721b23: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1cb23 (main + 0x27)
0xb20d5f: /lib/libc.so.6 + 0x14d5f (__libc_start_main + 0xdf)
0x80484c5: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x4c5


Expected results:
No crash

Additional info:
- Opening File menu does not create a crash.  
- In OOo 2.0 m139 official version, the procedure does not crash: instead, Help
says it cannot find the documentation for the Edit menu.  So, perhaps the crash
in Fedora is because it can't find the documentation.
Comment 1 Caolan McNamara 2005-11-21 04:54:06 EST
Yeah,  you're right, nasty problem. Easy to fix though. 
Comment 2 Caolan McNamara 2005-11-21 10:02:30 EST
*** Bug 173809 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.