Bug 173783 - NFS oops in kernel
NFS oops in kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-20 22:42 EST by W. Michael Petullo
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-07 23:16:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2005-11-20 22:42:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.12) Gecko/20051018 Epiphany/1.8.2

Description of problem:
While working on an NFSv4-hosted filesystem, I caused the following oops:

Oops: Kernel access of bad area, sig: 11 [#1]
Modules linked in: nfs(U) lockd(U) nfs_acl(U) parport_pc(U) lp(U) parport(U) autofs4(U) sunrpc(U) deflate(U) zlib_deflate(U) twofish(U) serpent(U) aes(U) blowfish(U) des(U) sha256(U) crypto_null(U) af_key(U) ipt_REJECT(U) ipt_state(U) ip_conntrack(U) nfnetlink(U) iptable_filter(U) ip_tables(U) nls_utf8(U) hfsplus(U) dm_mirror(U) dm_mod(U) ipv6(U) therm_adt746x(U) i2c_keywest(U) snd_powermac(U) snd_seq_dummy(U) snd_seq_oss(U) snd_seq_midi_event(U) snd_seq(U) snd_seq_device(U) snd_pcm_oss(U) snd_mixer_oss(U) snd_pcm(U) snd_timer(U) snd(U) soundcore(U) snd_page_alloc(U) hfc_usb(U) hisax(U) isdn(U) slhc(U) ehci_hcd(U) sungem(U) sungem_phy(U) ohci1394(U) ieee1394(U) ohci_hcd(U) ext3(U) jbd(U)
NIP: D2971864 LR: D29740B8 CTR: 00000000
REGS: c5d25a00 TRAP: 0300   Not tainted  (2.6.14-1.1663_FC5)
MSR: 00009032 <EE,ME,IR,DR>  CR: 44428488  XER: 00000000
DAR: 00000004, DSISR: 40000000
TASK = cf373330[3831] 'id3tag' THREAD: c5d24000
GPR00: 00000E0C C5D25AB0 CF373330 C5D25AB8 00000000 00000000 00000758 00000002
GPR08: CF44D17C D29A0000 CF44D174 C140209C 00000002 00000000 C0450000 D29971B4
GPR16: C2946BE8 00000756 C5D25D98 00000000 D2990000 D2700000 C0390000 C5D25B90
GPR24: D2700000 D2990000 D2973F50 CCABC258 C1402050 C1402088 C1402074 CCABC258
NIP [D2971864] encode_getfattr+0x4/0x30 [nfs]
LR [D29740B8] nfs4_xdr_enc_write+0x168/0x1a0 [nfs]
Call Trace:
[C5D25AB0] [D2974028] nfs4_xdr_enc_write+0xd8/0x1a0 [nfs] (unreliable)
[C5D25AF0] [D26D5934] rpcauth_wrap_req+0x94/0xc0 [sunrpc]
[C5D25B10] [D26CE798] call_transmit+0x188/0x270 [sunrpc]
[C5D25B30] [D26D4BAC] __rpc_execute+0x8c/0x290 [sunrpc]
[C5D25B50] [D26CEF00] rpc_call_sync+0x90/0xc0 [sunrpc]
[C5D25B80] [D296E134] nfs4_proc_write+0xb4/0x120 [nfs]
[C5D25BE0] [D2962D00] nfs_writepage_sync+0x180/0x2e0 [nfs]
[C5D25C20] [D296450C] nfs_updatepage+0x7c/0x2f0 [nfs]
[C5D25C50] [D29573A4] nfs_commit_write+0x14/0x30 [nfs]
[C5D25C60] [C00620C8] generic_file_buffered_write+0x3c8/0xa40
[C5D25D20] [C0063ED8] __generic_file_aio_write_nolock+0x308/0x500
[C5D25D90] [C00644AC] generic_file_aio_write+0x8c/0x170
[C5D25DD0] [D295773C] nfs_file_write+0xcc/0x120 [nfs]
[C5D25DF0] [C008BE28] do_sync_write+0xc8/0x150
[C5D25E90] [C008CF7C] do_readv_writev+0x32c/0x370
[C5D25F10] [C008D07C] sys_writev+0x4c/0xe0
[C5D25F40] [C000EBBC] ret_from_syscall+0x0/0x44
--- Exception: c00 at 0xe8b6ad4
    LR = 0xe8b6a8c
Instruction dump:
81810010 bba10014 38210020 7c0803a6 7d808120 4e800020 60000000 4800dcd1
4bffffb4 60000000 60000000 3d20d29a <80040004> 80840000 39698428 81498428


Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1663_FC5

How reproducible:
Always

Steps to Reproduce:
1.  Mount NFSv4 share.
2.  Try to use id3tag to edit an audio file's metadata (file on NFS share.)
  

Additional info:
Comment 1 W. Michael Petullo 2005-11-20 22:43:32 EST
I have not yet tried a newer kernel because it won't boot for me
(kernel-2.6.14-1.1688_FC5.)
Comment 2 Dave Jones 2005-12-01 02:21:32 EST
Do current kernels do any better ?
Comment 3 W. Michael Petullo 2005-12-01 17:14:57 EST
This is from 2.6.14-1.1729_FC5:

Oops: Kernel access of bad area, sig: 11 [#1]
Modules linked in: nfs(U) lockd(U) nfs_acl(U) parport_pc(U) lp(U) parport(U)
autofs4(U) sunrpc(U) ipt_REJECT(U) ipt_state(U) ip_conntrack(U) nfnetlink(U)
iptable_filter(U) ip_tables(U) nls_utf8(U) hfsplus(U) dm_mirror(U) dm_mod(U)
ipv6(U) therm_adt746x(U) snd_powermac(U) snd_seq_dummy(U) snd_seq_oss(U)
snd_seq_midi_event(U) snd_seq(U) snd_seq_device(U) snd_pcm_oss(U)
snd_mixer_oss(U) snd_pcm(U) snd_timer(U) snd(U) soundcore(U) snd_page_alloc(U)
ehci_hcd(U) sungem(U) sungem_phy(U) ohci1394(U) ieee1394(U) ohci_hcd(U) ext3(U)
jbd(U)
NIP: D27B1784 LR: D27B3FD8 CTR: 00000000
REGS: c2b03a00 TRAP: 0300   Not tainted  (2.6.14-1.1729_FC5)
MSR: 00009032 <EE,ME,IR,DR>  CR: 44228488  XER: 00000000
DAR: 00000004, DSISR: 40000000
TASK = c5e22dd0[3203] 'id3tag' THREAD: c2b02000
GPR00: 00000E0C C2B03AB0 C5E22DD0 C2B03AB8 00000000 00000000 00000758 00000002
GPR08: C274317C D27E0000 C2743174 C5E2009C 00000002 00000000 CCC107CC D27D6ECC
GPR16: C1487DEC 00000756 C2B03D98 00000000 D27D0000 D2640000 C0390000 C2B03B90
GPR24: D2640000 D27D0000 D27B3E70 C3A5C258 C5E20050 C5E20088 C5E20074 C3A5C258
NIP [D27B1784] encode_getfattr+0x4/0x30 [nfs]
LR [D27B3FD8] nfs4_xdr_enc_write+0x168/0x1a0 [nfs]
Call Trace:
[C2B03AB0] [D27B3F48] nfs4_xdr_enc_write+0xd8/0x1a0 [nfs] (unreliable)
[C2B03AF0] [D2619934] rpcauth_wrap_req+0x94/0xc0 [sunrpc]
[C2B03B10] [D2612798] call_transmit+0x188/0x270 [sunrpc]
[C2B03B30] [D2618BAC] __rpc_execute+0x8c/0x290 [sunrpc]
[C2B03B50] [D2612F00] rpc_call_sync+0x90/0xc0 [sunrpc]
[C2B03B80] [D27AE034] nfs4_proc_write+0xb4/0x120 [nfs]
[C2B03BE0] [D27A2C00] nfs_writepage_sync+0x180/0x2e0 [nfs]
[C2B03C20] [D27A440C] nfs_updatepage+0x7c/0x2f0 [nfs]
[C2B03C50] [D27972C4] nfs_commit_write+0x14/0x30 [nfs]
[C2B03C60] [C00618B8] generic_file_buffered_write+0x248/0xa20
[C2B03D20] [C00635A8] __generic_file_aio_write_nolock+0x308/0x500
[C2B03D90] [C0063B6C] generic_file_aio_write+0x8c/0x170
[C2B03DD0] [D279765C] nfs_file_write+0xcc/0x120 [nfs]
[C2B03DF0] [C008B348] do_sync_write+0xb8/0x140
[C2B03E90] [C008C49C] do_readv_writev+0x32c/0x370
[C2B03F10] [C008C59C] sys_writev+0x4c/0xe0
[C2B03F40] [C000F7D4] ret_from_syscall+0x0/0x38
--- Exception: c00 at 0xf6aaad4
    LR = 0xf6aaa8c
Instruction dump:
81810010 bba10014 38210020 7c0803a6 7d808120 4e800020 60000000 4800dca1
4bffffb4 60000000 60000000 3d20d27e <80040004> 80840000 39698148 81498148
Comment 4 W. Michael Petullo 2005-12-07 22:30:13 EST
2.6.14-1.1740_FC5 may be okay.  I have tested for a few hours now and have not
been able to trigger an oops.
Comment 5 Dave Jones 2005-12-07 23:16:31 EST
ok, reopen if it reoccurs.

Note You need to log in before you can comment on or make changes to this bug.