Bug 17379 - SIGHUP kills ntpd
Summary: SIGHUP kills ntpd
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: ntp   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-09 14:52 UTC by Olivier Baudron
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-09 14:52:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Olivier Baudron 2000-09-09 14:52:03 UTC
I installed ntp-4.0.99j-6 and tried to configure the statistics logs in the
way RedHat usually does. So, in /etc/ntp.conf I added:

statsdir /var/log/ntp/
statistics loopstats
filegen loopstats file loopstats type none enable

This generates a growing file '/var/log/ntp/loopstats' that I want to pass
through logrotate. However, when /bin/kill -HUP `pidof ntpd` is executed in
the postrotate processing, ntpd dies. And otherwise, ntp does not close and
reopen the file descriptors.

Comment 1 Jeff Johnson 2000-10-18 17:44:23 UTC
ntpd, because it's trying to maintain sub-millisecond accuracy, does not (and
cannot)
honor "killall -HUP ntpd" commands like other daemons.

Meanwhile, there's a mechanism using ntpdc with the filegen command to tell a
running
ntpd program to change log files, and you should be able to write a logrotate
script
that uses that mechanism if that's your desire. See the ntpd html documentation
for
details.

Meanwhile, I'm closing this as WONTFIX because adding SIGHUP restart support to
ntpd is
not gonna happen. Feel free to reopen this with a working logrotate script that
uses
ntpdc and filegen, and I'll add the script as an example to the ntp package.


Note You need to log in before you can comment on or make changes to this bug.