Bug 173809 - Openoffice crashes when opening Math help with locale set
Openoffice crashes when opening Math help with locale set
Status: CLOSED DUPLICATE of bug 173775
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-21 09:53 EST by Ottavio G. Rizzo
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-21 10:02:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ottavio G. Rizzo 2005-11-21 09:53:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
OO crashes when opening math help with LANG set to it_IT.UTF-8 or fr_FR.UTF-8. Notice that if LANG is unset everything works fine (apart from everything being in English)

Version-Release number of selected component (if applicable):
openoffice.org-math-2.0.0-3.2.1 openoffice.org-core-2.0.0-3.2.1 openoffice.org-langpack-it-2.0.0-3.2.1 

How reproducible:
Always

Steps to Reproduce:
1. Launch: LANG=it_IT.UTF-8 ooffice
2. Open the guide, e.g., by pressing F1
3. Choose the OpenOffice.org Math component
  

Actual Results:  OO hangs

Expected Results:  It should have showed the guide localized in Italian

Additional info:

This is the text OO invites me to copy in the bug report

0xe14028: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e028
0xe147ee: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e7ee
0x8c3420:  + 0x420 (__kernel_sigreturn + 0x0)
0x2995c27: /usr/lib/openoffice.org2.0/program/libucpchelp1.so + 0x2ac27
0x2995ef3: /usr/lib/openoffice.org2.0/program/libucpchelp1.so + 0x2aef3
0x2988418: /usr/lib/openoffice.org2.0/program/libucpchelp1.so + 0x1d418
0x35ecba: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x1ccba
0x3613e3: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x1f3e3 (ucb::Content::openStream() + 0xe9)
0x47f434: /usr/lib/openoffice.org2.0/program/libcomphelp4gcc3.so + 0x67434
0x47fcc6: /usr/lib/openoffice.org2.0/program/libcomphelp4gcc3.so + 0x67cc6 (comphelper::MediaDescriptor::addInputStream() + 0x1d6)
0x688735e: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x10c35e
0x6887921: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x10c921 (SfxMedium::GetInStream() + 0x9d)
0x68a91ca: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x12e1ca (SfxObjectShell::DoLoad(SfxMedium*) + 0x588)
0x68d8079: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x15d079 (SfxBaseModel::load(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 0x2f9)
0x68f3d47: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x178d47
0x6ca731b: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xe931b
0x6ca74d9: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xe94d9
0x6ca7592: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xe9592
0x6c11406: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x53406
0x68678e3: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xec8e3
0x6867da9: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xecda9
0x686961c: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xee61c
0x686965e: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xee65e
0x682206e: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xa706e
0x6869725: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xee725
0x686975c: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xee75c
0x5d93300: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x82300
0x5d9edce: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8ddce (Timer::Timeout() + 0x10)
0x5d9f148: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e148
0x27b8e51: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3ee51
0x27b8e3c: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3ee3c (SalData::Timeout() const + 0x24)
0x2629f0: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x189f0
0x2cbefe6: /usr/lib/libglib-2.0.so.0 + 0x24fe6
0x2cbd4ce: /usr/lib/libglib-2.0.so.0 + 0x234ce (g_main_context_dispatch + 0x1dc)
0x2cc04d6: /usr/lib/libglib-2.0.so.0 + 0x264d6
0x2cc09b8: /usr/lib/libglib-2.0.so.0 + 0x269b8 (g_main_context_iteration + 0x66)
0x262bcf: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x18bcf
0x27bfafa: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x45afa (X11SalInstance::Yield(unsigned char) + 0x28)
0x5d99594: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x88594 (Application::Yield() + 0x48)
0x5d995ca: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x885ca (Application::Execute() + 0x26)
0xdcec73: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x21c73 (desktop::Desktop::Main() + 0x15ab)
0x5d9e99f: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8d99f
0x5d9ea4f: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8da4f (SVMain() + 0x29)
0xdc9ad7: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1cad7 (sal_main + 0x57)
0xdc9b23: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1cb23 (main + 0x27)
0x125d5f: /lib/libc.so.6 + 0x14d5f (__libc_start_main + 0xdf)
0x80484c5: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x4c5
Comment 1 Caolan McNamara 2005-11-21 10:02:21 EST

*** This bug has been marked as a duplicate of 173775 ***

Note You need to log in before you can comment on or make changes to this bug.